Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26098 - [mediatomb] 0.12.1-5 - scripting broken

Attached to Project: Community Packages
Opened by Jeremy (jd1p3k) - Friday, 23 September 2011, 01:24 GMT
Last edited by Jonathan Conder (PirateJonno) - Sunday, 27 November 2011, 10:04 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jonathan Conder (PirateJonno)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

After running pacman -Syu and updating many packages scripting doesn't seem to work in mediatomb anymore. The log output in /var/log/mediatomb.log now shows:

2011-09-18 02:56:55 JS: function print() {
[native code]
}
2011-09-18 02:56:55 ERROR: missing objectType property
2011-09-18 02:56:55 ERROR: missing objectType property
2011-09-18 02:56:55 ERROR: missing objectType property
2011-09-18 02:56:55 ERROR: missing objectType property
...

Whenever adding new media and the database doesn't get updated with the new content.

I searched through /var/log/pacman.log to find out the updates that may have affected this:
[2011-09-11 05:00] upgraded ffmpegthumbnailer (2.0.6-1 -> 2.0.7-1)
[2011-09-11 05:00] upgraded js (1.8.5-2 -> 1.8.5-3)
[2011-09-11 05:01] upgraded taglib (1.7-1 -> 1.7-3)

I tried to downgrade them but this didn't seem to work. It seems that mediatomb needs some patches since this seems to have broken for other distros as well.

I posted on sourceforge because I did find someone using fedora had the same issue and they have patched it:
https://sourceforge.net/projects/mediat … ic/4547840
http://sourceforge.net/tracker/?func=de … tid=715782

** FIXED
I tested with the svn info here:
https://aur.archlinux.org/packages.php?ID=12602

And included the patch for mediatomb-0.12.1.jsparse.patch from here:
http://sourceforge.net/tracker/?func=de … tid=715782

Now the scripting is working as expected. It appears that the above patch (jparse.patch) needs to be added into the svn / community version of mediatomb.


Additional info:
* package version(s)
mediatomb 0.12.1-5

* config and/or log files etc.
N/A

Steps to reproduce:
1. pacman -Syu js # Get the latest updated js
2. Add content to mediatomb

Media doesn't get added to the database and you have errors in /var/log/mediatomb.log

This task depends upon

Closed by  Jonathan Conder (PirateJonno)
Sunday, 27 November 2011, 10:04 GMT
Reason for closing:  Won't fix
Additional comments about closing:  mediatomb is no longer in the repos

Loading...