Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26043 - libwebkit version is wacky

Attached to Project: Arch Linux
Opened by James Campos (aeosynth) - Saturday, 17 September 2011, 06:08 GMT
Last edited by Ionut Biru (wonder) - Saturday, 17 September 2011, 07:19 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

libwebkit's pkgbuild uses the development 1.5.2 version, but the package page shows the (outdated) stable 1.4.2.


http://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/libwebkit&id=1872ebb36fc96abee72eb8da2e7e8ff2bf2e5032

pkgver changed to 1.5.2


http://webkitgtk.org/?page=download

Development tree

You can also download the latest development release:

WebKitGTK+ 1.5.2 (9.2 MB)


http://www.archlinux.org/packages/extra/x86_64/libwebkit/

Package Details: libwebkit 1.4.2-1
This task depends upon

Closed by  Ionut Biru (wonder)
Saturday, 17 September 2011, 07:19 GMT
Reason for closing:  Not a bug
Comment by Ionut Biru (wonder) - Saturday, 17 September 2011, 07:06 GMT
libwebkit 1.5.2 is in gnome-unstable and trunk is ahead, because well is trunk. extra-i686 and extra-x86_64 are just snapshots from a previews trunk version.

http://projects.archlinux.org/svntogit/packages.git/tree/repos?h=packages/libwebkit
Comment by James Campos (aeosynth) - Saturday, 17 September 2011, 07:12 GMT
ok, even if trunk is ahead, it still shouldn't use dev packages if it's not marked as dev. what package is gnome-unstable?
Comment by Ionut Biru (wonder) - Saturday, 17 September 2011, 07:14 GMT
gnome-unstable is gnome 3.1.91(development) and libwebkit 1.5.2
Comment by James Campos (aeosynth) - Saturday, 17 September 2011, 07:17 GMT
could you give a link to gnome 3.1.91? I'm not having any luck finding it.

regardless, if gnome-unstable wants to use libwebkit-unstable, that's fine, but a separate package should be made for libwebkit-unstable, the stable libwebkit package shouldn't change to unstable.
Comment by Ionut Biru (wonder) - Saturday, 17 September 2011, 07:19 GMT

Loading...