Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26018 - [garcon] Missing "Education" icon.

Attached to Project: Arch Linux
Opened by René Herman (rene) - Wednesday, 14 September 2011, 20:18 GMT
Last edited by Tobias Powalowski (tpowa) - Tuesday, 14 February 2012, 14:25 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: After installing an "education" application (such as "stellarium", from extra) it shows up onder the Xfce menu category "Education", which the file

/usr/share/desktop-categories/xfce-education.directory

describes as being represented by the icon "applications-education". There is however no such icon available on an arch linux system -- at least not with only all the usual stuff installed. I have:

[rene@e600 ~]$ pacman -Q | grep icon
gnome-icon-theme 3.0.0-2
gnome-icon-theme-symbolic 3.0.0-1
gtk-update-icon-cache 2.24.6-2
hicolor-icon-theme 0.12-1
icon-naming-utils 0.8.90-2
tango-icon-theme 0.8.90-2

I've changed the Icon entry in the above directory file to "applications-science" which works for me.

I guess this might be an upstream issue -- but if so I hope that someone who knows which upstream to contact where and how can get it there. I haven't a clue how all this icon theme stuff is supposed to interact.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Tuesday, 14 February 2012, 14:25 GMT
Reason for closing:  Upstream
Comment by Jelle van der Waa (jelly) - Friday, 16 September 2011, 08:22 GMT
pkgfile /usr/share/desktop-categories/xfce-education.directory
nothing
???
Comment by René Herman (rene) - Friday, 16 September 2011, 09:27 GMT
Don't know about pkgfile (nothing here as well) but the directory file seems to have been installed by the "garcon" package:

[rene@e600 /var/cache/pacman/pkg]$ tar tJf garcon-0.1.8-1-i686.pkg.tar.xz
.PKGINFO
etc/
etc/xdg/
etc/xdg/menus/
etc/xdg/menus/xfce-applications.menu
[ ... ]
usr/share/desktop-directories/
usr/share/desktop-directories/xfce-network.directory
usr/share/desktop-directories/xfce-settings.directory
usr/share/desktop-directories/xfce-games.directory
usr/share/desktop-directories/xfce-education.directory
usr/share/desktop-directories/xfce-other.directory
usr/share/desktop-directories/xfce-office.directory
usr/share/desktop-directories/xfce-accessories.directory
usr/share/desktop-directories/xfce-screensavers.directory
usr/share/desktop-directories/xfce-development.directory
usr/share/desktop-directories/xfce-system.directory
usr/share/desktop-directories/xfce-multimedia.directory
usr/share/desktop-directories/xfce-graphics.directory
[ ... ]
Comment by Paul Bredbury (brebs) - Saturday, 17 September 2011, 16:47 GMT
Easy workaround:

sed -i -e "s:Icon=applications-education:Icon=applications-science:1" data/xfce/xfce-education.directory.in
Comment by Andreas Radke (AndyRTR) - Sunday, 23 October 2011, 16:32 GMT
please report this upstream. garcon is a Xfce project.
Comment by René Herman (rene) - Sunday, 23 October 2011, 18:04 GMT
The garcon package doesn't supply icons by design though. The XFCE desktop-directory files refer to generic icon names (such as applications-accesories which does exist or, in this case, applications-education which doesn't) and it seems to be the distribution's responsibility to supply these icons.

Given that neither the gnome nor the Tango icon-theme package supplies an applications-education icon, the right answer MIGHT indeed be to change the entry in the garcon desktop-directory file, but in principle it seems to be an issue that's up to the distribution.
Comment by René Herman (rene) - Tuesday, 25 October 2011, 01:51 GMT
Adding... the oxygen icon-theme (pacman -S oxygen-icons oxygen-icons-svg oxygen-gtk) does in fact supply an applications-education icon.

Clearly a bit of overkill to install an entire icon theme for just the one icon but it would seem to be an argument as to the question of who is supposed to provide what.

Loading...