Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25997 - [strace] perl package

Attached to Project: Arch Linux
Opened by Mick (earnon) - Tuesday, 13 September 2011, 22:05 GMT
Last edited by Giovanni Scafora (giovanni) - Saturday, 01 October 2011, 06:00 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Giovanni Scafora (giovanni)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The 'strace' binary doesn't need 'perl' package (add this in optional depend).


Additional info:
* package version(s): 4.6-1


Steps to reproduce:
In a terminal, use the next command

[root@host ~]# pacman -Ql strace | grep 'bin/[a-z]'
strace /usr/bin/strace
strace /usr/bin/strace-graph

[root@host ~]# file $(pacman -Ql strace | cut -d' ' -f2) | grep perl
/usr/bin/strace-graph: a /usr/bin/perl script, ASCII text executable

[root@host ~]# ldd /usr/bin/strace | grep perl
nothing
This task depends upon

Closed by  Giovanni Scafora (giovanni)
Saturday, 01 October 2011, 06:00 GMT
Reason for closing:  Not a bug

Loading...