Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25911 - [scribes] word completion does not work

Attached to Project: Community Packages
Opened by Hugo Osvaldo Barrera (hobarrera) - Tuesday, 06 September 2011, 23:49 GMT
Last edited by György Balló (City-busz) - Wednesday, 04 September 2013, 21:21 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jaroslav Lichtblau (Dragonlord)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Word completition is run using /usr/bin/python and does not work.

Here's a patch that fixes this:
https://bbs.archlinux.org/viewtopic.php?pid=925844#p925844
This task depends upon

Closed by  György Balló (City-busz)
Wednesday, 04 September 2013, 21:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  scribes-0.4.954-4
Comment by mattia (nTia89) - Monday, 20 February 2012, 20:50 GMT
please report version and how to reproduce the issue
Comment by Hugo Osvaldo Barrera (hobarrera) - Wednesday, 29 February 2012, 09:51 GMT
<Deleted accidental double-post (pressed enter twice)>
Comment by Hugo Osvaldo Barrera (hobarrera) - Wednesday, 29 February 2012, 09:51 GMT
I haven't used scribes in months, so I tested what the status of this issue is.
When scribes loads, it fails miserably to load to load the word completition module, and some other thing.
Just run scribes! :)

$ scribes
$ Traceback (most recent call last):
File "/usr/lib/scribes/GenericPlugins/WordCompletion/SuggestionProcess/ScribesWordCompletionSuggestionGenerator.py", line 5, in <module>
from SCRIBES.Utils import fork_process
ImportError: No module named SCRIBES.Utils
Traceback (most recent call last):
File "/usr/lib/scribes/GenericPlugins/RecentOpen/ExternalProcess/ScribesRecentFilesIndexer.py", line 8, in <module>
from gobject import MainLoop, threads_init
File "/usr/lib/python2.7/site-packages/gobject/__init__.py", line 26, in <module>
from glib import spawn_async, idle_add, timeout_add, timeout_add_seconds, \
File "/usr/lib/python2.7/site-packages/glib/__init__.py", line 22, in <module>
from glib._glib import *
ImportError: /usr/lib/libpyglib-2.0-python2.so.0: undefined symbol: _Py_ZeroStruct
Traceback (most recent call last):
File "/usr/lib/scribes/GenericPlugins/WordCompletion/IndexerProcess/ScribesWordCompletionIndexer.py", line 3, in <module>
from SCRIBES.Utils import fork_process
ImportError: No module named SCRIBES.Utils



Version is 0.4.954-1
Comment by mattia (nTia89) - Wednesday, 29 February 2012, 13:55 GMT
i build scribes with abs and applying or not the patch nothing change.

i can't reproduce the issue .....
Comment by Hugo Osvaldo Barrera (hobarrera) - Wednesday, 29 February 2012, 14:04 GMT
I'm using the prebuilt package from community. Not sure what patch you're talking about.
Comment by mattia (nTia89) - Wednesday, 29 February 2012, 15:55 GMT
in the forum ..... your link .....
Comment by Hugo Osvaldo Barrera (hobarrera) - Tuesday, 06 March 2012, 12:11 GMT
Is is possible that you have some other packages that might be a dependancy for this to work as is not listed? A clean install of this package still gives the same output error.
Comment by mattia (nTia89) - Tuesday, 06 March 2012, 12:57 GMT
could be, but how i can check it ?
Comment by Hugo Osvaldo Barrera (hobarrera) - Wednesday, 07 March 2012, 23:11 GMT
Run scribes from a terminal emulator (like xterm) and notice the output.
Comment by mattia (nTia89) - Thursday, 08 March 2012, 19:32 GMT
i get:

[mattia@arch-desktop ~]$ scribes
[mattia@arch-desktop ~]$ Traceback (most recent call last):
File "/usr/lib/scribes/GenericPlugins/WordCompletion/SuggestionProcess/ScribesWordCompletionSuggestionGenerator.py", line 5, in <module>
from SCRIBES.Utils import fork_process
ImportError: No module named SCRIBES.Utils
Traceback (most recent call last):
File "/usr/lib/scribes/GenericPlugins/RecentOpen/ExternalProcess/ScribesRecentFilesIndexer.py", line 8, in <module>
from gobject import MainLoop, threads_init
File "/usr/lib/python2.7/site-packages/gobject/__init__.py", line 26, in <module>
from glib import spawn_async, idle_add, timeout_add, timeout_add_seconds, \
File "/usr/lib/python2.7/site-packages/glib/__init__.py", line 22, in <module>
from glib._glib import *
ImportError: /usr/lib/libpyglib-2.0-python2.so.0: undefined symbol: _Py_ZeroStruct
/usr/lib/python2.7/site-packages/SCRIBES/Main.py:10: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
main()
Traceback (most recent call last):
File "/usr/lib/scribes/GenericPlugins/WordCompletion/IndexerProcess/ScribesWordCompletionIndexer.py", line 3, in <module>
from SCRIBES.Utils import fork_process
ImportError: No module named SCRIBES.Utils
^C
[mattia@arch-desktop ~]$

Loading...