Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25873 - [xfce4-screenshooter] segfaults trying to capture screenshot of active window in awesome WM

Attached to Project: Arch Linux
Opened by Matthias Kr├╝ger (matthiaskrgr) - Saturday, 03 September 2011, 10:22 GMT
Last edited by Evangelos Foutras (foutrelis) - Wednesday, 23 November 2011, 12:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Andreas Radke (AndyRTR)
Evangelos Foutras (foutrelis)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I use awesomeWM and when I try to make a screenshot of the window under the cursor, xfce4-screenshoter segfaults.


Additional info:
* package version(s)
awesome 3.4.10-2
xfce4-screenshooter 1.8.0-1
* config and/or log files etc.

(gdb) start xfce4-sceenshooter
No symbol table loaded. Use the "file" command.
(gdb) run
Starting program: xfce4-sceenshooter
No executable file specified.
Use the "file" or "exec-file" command.
(gdb) exec-file /usr/bin/xfce4-screenshooter
(gdb) run
Starting program: /usr/bin/xfce4-screenshooter xfce4-sceenshooter
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
0x0000000000409535 in ?? ()
(gdb) bt
#0 0x0000000000409535 in ?? ()
#1 0x0000000000000000 in ?? ()
(gdb) bt full
#0 0x0000000000409535 in ?? ()
No symbol table info available.
#1 0x0000000000000000 in ?? ()
No symbol table info available.
(gdb)



Steps to reproduce:
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Wednesday, 23 November 2011, 12:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  xfce4-screenshooter 1.8.0-2
Comment by Andreas Radke (AndyRTR) - Sunday, 23 October 2011, 09:41 GMT
Seems to work for me under Awesome. Try to remove any xfce4-screenshoter config dir/files.
Comment by Andreas Radke (AndyRTR) - Sunday, 23 October 2011, 09:43 GMT
Ah. Only the fullscreen mode seems to work here. The window mode also segfaults. But this could be Awesome related too. Feel free to debug this together with both upstream projects.
Comment by Evangelos Foutras (foutrelis) - Friday, 28 October 2011, 19:35 GMT
Comment by Evangelos Foutras (foutrelis) - Wednesday, 23 November 2011, 12:30 GMT
I applied a proposed patch from Xfce's bugzilla. Reopen if the issue is not solved.

Loading...