Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25851 - FTDI USB-Serial converter dropping bytes

Attached to Project: Arch Linux
Opened by Alex Forencich (alex.forencich) - Thursday, 01 September 2011, 02:48 GMT
Last edited by Tobias Powalowski (tpowa) - Thursday, 01 September 2011, 07:14 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: I have an FTDI USB to RS232 chip on a development board that is dropping received bytes. The issue does not appear in Ubuntu. I can run the link with heavy data transfer for more than 10 minutes with no issues in Ubuntu, however in Arch it consistently drops bytes within two minutes of initiating communications.

Please let me know if there is any more information I need to pass along.

Additional info:
* Everything up to date
* Same problem on both i386 and x86_64


Steps to reproduce:
* Connect FTDI USB to Serial adapter
* Send lots of bytes for 10 minutes and see how many get lost
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Thursday, 01 September 2011, 07:14 GMT
Reason for closing:  Not a bug
Comment by Tobias Powalowski (tpowa) - Thursday, 01 September 2011, 05:21 GMT
Please look at the kernel config options ubuntu uses and we use.
Comment by Alex Forencich (alex.forencich) - Thursday, 01 September 2011, 06:33 GMT
Turns out that Ubuntu has ixon cleared while Arch has ixon set. The register containing the flag in the termios structure was not initialized in my application and as a result any time the device replied with a hex 13 it got eaten by the serial port driver. One line of C later and the problem is solved.

Loading...