Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#2583 - pacman HTTP implementation does not use Last-Modified header

Attached to Project: Pacman
Opened by Viktor Peters (Mythoz) - Friday, 15 April 2005, 15:59 GMT
Last edited by Roman Kyrylych (Romashka) - Saturday, 25 November 2006, 13:09 GMT
Task Type Feature Request
Category
Status Closed
Assigned To Aaron Griffin (phrakture)
Architecture not specified
Severity Low
Priority Normal
Reported Version 0.7 Wombat
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Usually I prefer HTTP over FTP because of its faster login and proxy related stuff.

But it seems pacman's HTTP library does not use Last-Modified header as it does for FTP. So the repository database is always downloaded.

Not all HTTP server respond with a Last-Modified header but some are, so it should be used.

You can use the HEAD command instead of GET for querying headers without downloading the file.

Example response from http://ftp.archlinux.de:
------
$ telnet ftp.archlinux.de 80
Trying 129.70.34.180...
Connected to ftp.archlinux.de.
Escape character is '^]'.
HEAD /pub/archlinux/current/os/i686/current.db.tar.gz HTTP/1.1
Host: ftp.archlinux.de
Connection: keep-alive

HTTP/1.1 200 OK
Date: Fri, 15 Apr 2005 15:39:09 GMT
Server: Apache/1.3.26 (Unix) Debian GNU/Linux
Last-Modified: Thu, 14 Apr 2005 22:42:42 GMT
ETag: "a8046-b507-425ef1e2"
Accept-Ranges: bytes
Content-Length: 46343
Keep-Alive: timeout=15, max=100
Connection: Keep-Alive
Content-Type: application/x-tar
Content-Encoding: x-gzip

Connection closed by foreign host.
------
This task depends upon

Closed by  Aaron Griffin (phrakture)
Monday, 27 November 2006, 18:06 GMT
Reason for closing:  Implemented
Additional comments about closing:  Fixed in pacman3 (libdownload)
Comment by Judd Vinet (judd) - Monday, 18 April 2005, 00:04 GMT
Yes, this is on our TODO list for the libified pacman (3.0). I don't think it will be done in the 2.x series though.
Comment by Roman Kyrylych (Romashka) - Saturday, 25 November 2006, 13:09 GMT
Isn't this implemented in pacman3 and libdownload?

Loading...