Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#25804 - [octave] requires GraphicsMagick configured with '--with-quantum-depth=16' option

Attached to Project: Arch Linux
Opened by vincent (altrus) - Sunday, 28 August 2011, 22:18 GMT
Last edited by Ronald van Haren (pressh) - Monday, 23 December 2013, 19:45 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No



When using imwrite in octave, the following warning appears:

octave:22> imwrite(picture, 'test.jpg', 'Quality', 100); %Write image
warning: your version of GraphicsMagick limits images to 8 bits per pixel

This error does not occur when graphicsmagick is configured with the '--with-quantum-depth=16' flag, and subsequently compiled.

This task depends upon

Closed by  Ronald van Haren (pressh)
Monday, 23 December 2013, 19:45 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.6.4-4
Comment by vincent (altrus) - Sunday, 28 August 2011, 22:25 GMT
As an unrelated aside, it would be nice to have the package also compiled with openmp support to better take advantage of multicore processors. This is enabled at compile time with the '--enable-openmp' configuration option.
Comment by Vedant Kumar (vsk) - Tuesday, 13 September 2011, 06:43 GMT
I modified the PKGBUILD to add the quantum depth flag. Incidentally, I think I saw the -fopenmp flag in the compile output. I've linked the resulting package, as it's too large to fit as an attachment [64-bit].

Hope this helps.
Comment by vincent (altrus) - Monday, 19 September 2011, 23:44 GMT
Thank you very much! It does work. Would you mind providing the pkgbuild you used? I was having trouble modifying the AUR version to work without breaking other packages.

Warm Regards,

Comment by Vedant Kumar (vsk) - Monday, 19 September 2011, 23:56 GMT
I didn't touch the version number. Here's the PKGBUILD anyway:

I'm glad it worked!
Comment by Matěj Týč (bubla) - Sunday, 02 June 2013, 15:51 GMT
  • Field changed: Percent Complete (100% → 0%)
Current graphicsmagick comes without that flag, so Octave can't handle 16-bit images again.
Comment by vincent (altrus) - Monday, 12 August 2013, 01:22 GMT
I can also confirm this regression; if possible, can you please compile with the appropriate (--with-quantum-depth=16) flag.
Comment by vincent (altrus) - Monday, 12 August 2013, 17:52 GMT
I've attached a copy of the desired PKGBUILD that compiles to the current graphicsmagick (from ABS), and also includes appropriate performance flags "--with-openmp, --with-threads, --with-quantum-depth=16".
   PKGBUILD (1.8 KiB)