Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25747 - python and python2 packages don't reflect kernel upgrade to 3.0

Attached to Project: Arch Linux
Opened by Raphaël Bois (vdust) - Wednesday, 24 August 2011, 14:02 GMT
Last edited by Stéphane Gaudreault (stephane) - Monday, 17 October 2011, 14:07 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Stéphane Gaudreault (stephane)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Python's module 'sys' has an attribute 'platform'. In python documentation (both 2.x and 3.x), you can find this line in the description:

" For Unix systems, this is the lowercased OS name as returned by uname -s with the first part of the version as returned by uname -r appended, e.g. 'sunos5' or 'linux2', AT THE TIME WHEN PYTHON WAS BUILT. "

I currently have linux 3.0 installed, but sys.platform still says 'linux2'. So python packages seems to need a rebuild.

Additional info:
* package version(s):
python 3.2.1-1
python2 2.7.2-2

Steps to reproduce:
$ uname -s -r
Linux 3.0-ARCH
$ python #or python2
...
>>> import sys
>>> sys.platform
'linux2'
This task depends upon

Closed by  Stéphane Gaudreault (stephane)
Monday, 17 October 2011, 14:07 GMT
Reason for closing:  Not a bug
Comment by Jakob Matthes (jakobm) - Wednesday, 24 August 2011, 22:51 GMT
Upstream has decided to remove the version number from sys.platform, see http://bugs.python.org/issue12795 and http://bugs.python.org/issue12326 for the discussion.
Comment by Jan de Groot (JGC) - Thursday, 25 August 2011, 15:01 GMT
Yay, loads of comments in those bugreports and nobody agrees. I would say: force linux2 in our current versions of python and let it change to "linux" when we upgrade to python 3.3. When it's time to rebuild all python modules, I think it's also time to break broken modules.

Thanks for pointing this issue out, it will save us from busting python whenever we build it on a system with linux 3.x running.
Comment by Stéphane Gaudreault (stephane) - Monday, 17 October 2011, 14:00 GMT
Upstream decision was to avoid break modules and use linux2 everywhere. I commited a patch in september to force linux2 on python2 and the version 3.2.2 was fixed upstream.
Comment by Stéphane Gaudreault (stephane) - Monday, 17 October 2011, 14:07 GMT
Note for future reference : python 3.3 will probably set sys.platform to "linux", but python2 will continue to use linux2.

Loading...