Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25736 - [ffmpegthumbnailer]

Attached to Project: Arch Linux
Opened by Max (zoidberg) - Tuesday, 23 August 2011, 17:45 GMT
Last edited by Ionut Biru (wonder) - Sunday, 11 September 2011, 10:03 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
gvfs support doesn't seems to be enabled, flag --enable-gnome-vfs is maybe missing? (whereas gvfs is marked as an optional dependency).

on the google code page of ffmepgthumbnailer there is:

ffmpegthumbnailer version 2.0.3 (August 06, 2010)
Support for gnome-vfs uris added. New configure flag (--enable-gnome-vfs), this puts a runtime dependancy on libgnome-vfs-2.0


Additional info:
* package version(s)
ffmpegthumbnailer 2.0.6-1 x86_64


Steps to reproduce:

ffmpegthumbnailer -s 128 -i smb://nas/test.mov -o /tmp/.gnome_desktop_thumbnail.YZPJ0V -c png -f -t 10
Error: Could not open input file: smb://nas/test.mov

(/usr/bin/totem-video-thumbnailer -s 128 smb://nas/test.mov /tmp/.gnome_desktop_thumbnail.YZPJ0V works fine)
This task depends upon

Closed by  Ionut Biru (wonder)
Sunday, 11 September 2011, 10:03 GMT
Reason for closing:  Not a bug
Additional comments about closing:  gio support is only for local path in ffmpegthumbnailer.
Comment by Ionut Biru (wonder) - Tuesday, 23 August 2011, 17:49 GMT
first gvfs != gnome-vfs

gnome-vfs is deprecated for a long time
Comment by Max (zoidberg) - Tuesday, 23 August 2011, 17:58 GMT
Oups, Sorry, so maybe this one is missing:
ffmpegthumbnailer version 2.0.5 (November 30, 2010)
Replaced deprecate gnome-vfs with gio (--enable-gio)
??
Comment by Ionut Biru (wonder) - Tuesday, 23 August 2011, 18:00 GMT
exactly, that is the best solution, which is enabled by default in our package
Comment by Max (zoidberg) - Tuesday, 23 August 2011, 18:24 GMT
paths like smb://... are gvfs mounts, no? ffmpegthumbnailer seems to be unable to access such paths, is it normal? (Return error is: Error: Could not open input file: smb://..., totem-video-thumbnailer works fine with the same path)
Comment by Jan de Groot (JGC) - Wednesday, 24 August 2011, 23:49 GMT
The way ffmpegthumbnailer works, you'll probably have to mount the location first. Just like epiphany with FTP, ffmpegthumbnailer doesn't contain any code to mount anything.
Comment by Max (zoidberg) - Saturday, 27 August 2011, 10:10 GMT
As I understood smb://... are gvfs path, these paths are added by nautilus itself (%u option in /usr/share/thumbnailers/... it was not a handmade test) when I try to use ffmegthumbnailer instead of totem-video-thumbnailer in order to create thumbnails in nautilus.
I thought the --enable-gio option was written to enable this feature. Am I wrong?
Comment by Ronald van Haren (pressh) - Friday, 02 September 2011, 16:52 GMT
I'm not sure if it is supposed to do that, but I doubt it is. Maybe you can ask the upstream dev if it is supposed to generate thumbnails for smb paths directly?
Comment by Max (zoidberg) - Sunday, 11 September 2011, 09:15 GMT
Here is the answer from the dev: "Correct, gio is supported only for local files. This means you can thumbnail file://somefile.avi but no network paths. I added a an extra logging to the source code to make this clear."
So this is the normal behaviour, this thread could be closed.
Sorry.

Loading...