Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#25733 - [gnutls] 3.0.0 -> 3.0.1 breaks Google Calender sync

Attached to Project: Arch Linux
Opened by Niklas Schnelle (spacenick) - Tuesday, 23 August 2011, 15:20 GMT
Last edited by Ionut Biru (wonder) - Friday, 16 September 2011, 18:27 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Ionut Biru (wonder)
Jan Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No



Hi Arch Team,

when trying to add a Google Calendar to Evolution I get a TLS Handshake error when using gnutls 3.0.1.
Downgrading to 3.0.0 solves the issue.
I tried bisecting but when building upstream gnutls it doesn't seem to get used by Evolution at least the version tagged 3.0.0

when simply compiled, build and installed without a PKGBUILD doesn't fix it like the Arch package of 3.0.0 does.

Greetings Nik

Additional info:
* package version(s)
* config and/or log files etc.

Steps to reproduce:
This task depends upon

Closed by  Ionut Biru (wonder)
Friday, 16 September 2011, 18:27 GMT
Reason for closing:  Fixed
Additional comments about closing:  glib-networking-2.28.7-5
Comment by Ionut Biru (wonder) - Tuesday, 23 August 2011, 18:22 GMT
i have no idea how this works. evolution doesn't link to gnutls and doesn't use it at all.

is this google calendar support built in evolution or is a separate plugin?
Comment by Jan de Groot (JGC) - Wednesday, 24 August 2011, 08:19 GMT
AFAIK evolution has built-in support for this and it uses libsoup for HTTP communication. libsoup uses gnutls for SSL.
Comment by Ionut Biru (wonder) - Wednesday, 24 August 2011, 09:06 GMT
please try the new glib-networking from here:
Comment by Niklas Schnelle (spacenick) - Wednesday, 24 August 2011, 10:54 GMT
Doesn't fix it here, though when adding the calendar newly the error message is gone it doesn't sync
Comment by Jakob Matthes (jakobm) - Thursday, 25 August 2011, 12:59 GMT
The new glib-networking is not fixing it here.
Error message on this machine reads: "The TLS connection was non-properly terminated."
Comment by Ionut Biru (wonder) - Thursday, 25 August 2011, 15:08 GMT
new packages available, same pkgrel. be sure you delete the old package from cache (pacman -Scc)
Comment by Jakob Matthes (jakobm) - Saturday, 27 August 2011, 09:17 GMT
Just downloaded evolution and all dependencies (including the already installed) again from the server and reinstalled them.

I can refresh the list of available calendars from the server (i.e. some connection is made), but I get the same error as before, when trying to show/refresh the calendar itself. I'm not using evolution usually and don't know how to debug this.
Comment by Ionut Biru (wonder) - Saturday, 27 August 2011, 09:19 GMT
have you tried the glib-networking package from ?
Comment by Jakob Matthes (jakobm) - Saturday, 27 August 2011, 09:29 GMT
evolution 3.0.2-1
glib-networking 2.28.7-5
libsoup 2.34.3-1
libsoup-gnome 2.34.3-1

Yes, I got the glib-networking from your url.
I see some https/sslv3 traffic to
Comment by Muflone (muflone) - Monday, 29 August 2011, 18:17 GMT
I'm experiencing the same issue.

evolution 3.0.2-1
gnutls 3.0.1-1
glib-networking 2.28.7-5
libsoup 2.34.3-1
libsoup-gnome 2.34.3-1

With gnutls 3.0.1 the following message is reported after the password request:
"Impossibile aprire il calendario: Restituito codice di stato HTTP 6 inatteso (Errore nel leggere dati dal socket TLS: The TLS connection was non-properly terminated.)"

Using gnutls 3.0.0 the message won't show up but the calendar doesn't show/sync anything.
Comment by Jeremy Newton (Mystro256) - Tuesday, 30 August 2011, 22:47 GMT
I get the same thing as Mulflone, with the same versions and all that.

I'm on x86_64, and deleting the old packages from cache and reinstalling gnutls has provided nothing it seems. I would assume this is just a regression of gnutls.
Comment by Yonathan Dossow (ydossow) - Wednesday, 31 August 2011, 14:23 GMT
same problem here:

e-cal-backend-caldav-WARNING **: Server did not response with 207, but with code 6 (SSL handshake failed)

$ pacman -Q evolution evolution-data-server libsoup libsoup-gnome gnutls glib-networking
evolution 3.0.3-1
evolution-data-server 3.0.3-1
libsoup 2.34.3-1
libsoup-gnome 2.34.3-1
gnutls 3.0.1-1
glib-networking 2.28.7-5
Comment by Ionut Biru (wonder) - Wednesday, 31 August 2011, 14:30 GMT
As we don't know if is a gnutls or a evo/glib-networking problem, please only submit a comment only if you have a clue. I tried everything that i found related to gnutls and gnome, more expect only in gnome 3.2
Comment by Jeremy Newton (Mystro256) - Wednesday, 31 August 2011, 15:05 GMT
Well in my honest opinion, it seems like it's either a regression in gnutls or perhaps a change in gnutls that hasn't been adapted in libsoup or glib-networking (I would think the former but I can't say for sure). It doesn't seem like an evolution problem, more of the libraries surrounding it.
Comment by Yonathan Dossow (ydossow) - Wednesday, 31 August 2011, 17:20 GMT
I bisected gnutls, and the commit 16b552803790c0f1b393b6f143b166429c51e9f2 introduces the issue. Reverting it fixes the issue.
Comment by Ionut Biru (wonder) - Wednesday, 31 August 2011, 17:34 GMT
@Yonathan can you submit this patch upstream for review and paste the link here for the report?
Comment by Ionut Biru (wonder) - Friday, 02 September 2011, 08:38 GMT
Comment by Ionut Biru (wonder) - Thursday, 15 September 2011, 19:49 GMT
Comment by Ionut Biru (wonder) - Friday, 16 September 2011, 18:24 GMT
thanks to fredbezies who reported upstream, we have now a fix in less than 24 hours. I hope this is a good lesson for everyone who didn't do a thing about this bug.

reporting upstream is the proper way to fix bugs in software.