Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25723 - [couchdb] packaged version is unstable

Attached to Project: Community Packages
Opened by Matt Freeman (mattopenstack) - Tuesday, 23 August 2011, 08:04 GMT
Last edited by Sergej Pupykin (sergej) - Thursday, 20 October 2011, 11:36 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
CouchDB package which has previously tracked the Apache CouchDB releases within days has for some unexplained reason made the jump 1.1.0-3294343svn (which is branded 1.2.0x in Futon). This snapshot of the trunk is seriously buggy, commonjs includes on shows/lists dont work for example.

Rather than tackle this bug I think the couchdb package should be tracking the releases of CouchDB, as it has previously done, rather than some random point in the SVN trunk. Unlike some other projects CouchDB is highly unstable outside the releases, following the releases as soon as they come out meets the Arch mantra perfectly (obviously how we follow releases/version is depending on the projects). If Arch mantra is follow the SVN trunk, Git HEAD etc.. with 'it compiles it works' then I'll shut up.

Disappointed this made into community

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Sergej Pupykin (sergej)
Thursday, 20 October 2011, 11:36 GMT
Reason for closing:  No response
Comment by Sergej Pupykin (sergej) - Tuesday, 23 August 2011, 10:06 GMT
Please try couchdb-1.1.0-1.svn20110823 (reason was js package compatibility)
Comment by Matt Freeman (mattopenstack) - Saturday, 27 August 2011, 02:54 GMT
Sergej

Could you not of compile 1.1.0 against JS (which is SpiderMonkey 1.8.5)?

Or alternatively we can localize the dependency on SpiderMonkey using --with-js-lib and --with-js-include

Still issues e.g.
Using commonjs require fails on shows and lists (and probably views too) - A CRITICAL BUG
cant save a temporary view in Futon:
'Cannot save view because the design document language is "undefined", not "javascript".'

Moving CouchDB along with SpiderMonkey is a simply a recipe for disaster.
Comment by Sergej Pupykin (sergej) - Monday, 29 August 2011, 12:51 GMT
Please describe what do you do exactly. I successfully created view as described in http://wiki.apache.org/couchdb/HTTP_view_API#Creating_Views

Loading...