Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25702 - Any form of shutdown reboots instead

Attached to Project: Arch Linux
Opened by Pubby Eight (pubby8) - Sunday, 21 August 2011, 18:27 GMT
Last edited by Gaetan Bisson (vesath) - Thursday, 16 August 2012, 13:24 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
Shutting down the computer does not poweroff and instead reboots. All forms of shutdown have this problem, besides manually holding the computer's power button.

Removing daemons (netcfg or networkmanager have been tested) that are related to wireless network will fix the problem. The "network" daemon does not cause this.

Additional info in this forum thread:
https://bbs.archlinux.org/viewtopic.php?id=102178&p=1
(others may have same problem but different cause)

Additional info:
Kernel 3.0

netcfg 2.6.7-1
dhcpcd 5.2.12-1 (base)
wpa_supplicant 0.7.3-3 (base)
(Packages were recent at time of posting)

Wireless driver: rtl2860sta - ASUS PCE-n13 wireless card

This task depends upon

Closed by  Gaetan Bisson (vesath)
Thursday, 16 August 2012, 13:24 GMT
Reason for closing:  No response
Comment by Gerardo Exequiel Pozzi (djgera) - Sunday, 21 August 2011, 18:48 GMT
In that case, use an initscripts hook to remove conflicting loaded module before shutdown to workaround.

cat << FIN > /etc/rc.d/functions.d/workaround_blah
workaround_blah() {
modprobe -r broken_module_here
}

add_hook shutdown_poweroff workaround_blah
FIN
Comment by Pubby Eight (pubby8) - Tuesday, 23 August 2011, 20:57 GMT
@djgera
What is the conflicting module? How would I find out?- very new to linux.
Comment by Gerardo Exequiel Pozzi (djgera) - Tuesday, 23 August 2011, 23:51 GMT
The module that is loaded for your wireless card should be. Use lsmod to see module name.
Ask in forums for better support ;)
Comment by Dennis Hodapp (thehodapp) - Thursday, 29 September 2011, 01:42 GMT
Hi djgera,
I've tried your suggestion and it does not work for me. For my specific BIOS, disabling "Integrated NIC" fixes the problem (at the cost of no wired Internet). Others have the BIOS option "wakeup on LAN" or similar that they can disable to fix the problem. Running the latest kernel 3.0-ARCH. Would be happy to provide more information if someone can figure out the cause.
Comment by BP (kichawa) - Thursday, 01 December 2011, 13:27 GMT
if i stop network deamon, i could shutdown
i'll try to turn off WoL...
Comment by Jelle van der Waa (jelly) - Friday, 20 January 2012, 17:19 GMT
Status?
Comment by Borromini (Borromini) - Thursday, 16 February 2012, 08:22 GMT
Alas, I am joining the club. Thought it was an issue with the latest initscripts update (initscripts 2012.02.1-1 to 2012.01.3-1) but rolling back does not work. Running the LTS kernel (3.0.21-lts at this time).

As suggested in some forum thread, I added the -P option to the shutdown command, but no dice: it stubbornly keeps rebooting instead of shutting down (# shutdown -hP now).
Comment by Boris Nadezhdin (6opuc) - Thursday, 23 February 2012, 11:21 GMT
I have the same issue with shutdown/restart.

Edit: turning off acpid, laptop-mode and cpufreq daemons makes restarts to occur not so often...
Comment by cfr (cfr42) - Wednesday, 04 April 2012, 02:57 GMT
Try disabling PM runtime e.g. powertop and laptop-mode tools can or do enable this. Disabling it worked here.

Loading...