Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#25687 - i686 Arch Linux 2011.08.19 installation CD boots but fails to find installation media.

Attached to Project: Release Engineering
Opened by chris_debian (chris_debian) - Saturday, 20 August 2011, 12:07 GMT
Last edited by Eric Belanger (Snowman) - Saturday, 25 August 2012, 13:21 GMT
Task Type Bug Report
Category Hardware Issues
Status Closed
Assigned To No-one
Architecture i686
Severity High
Priority Normal
Reported Version testbuild (specify!)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi,

Just downloaded the i686 Arch Linux 2011.08.19 iso. It booted fine, but failed to find the CDROM that I booted from.

The last messages I saw were:

Starting udevde
Running Hook [udev]
Triggering uevents...done.
Running Hook [memdisk]
Running Hook [archiso]
Running Hook [archiso_pxe_ndb]
Running Hook [archiso_loop_mnt]
Waiting for boot device...
Waiting 30 seconds for device /dev/disk/by-label/ARCH_201108 ...
ERROR: boot device didn't show up after 30 seconds
Falling back to interactive prompt.

I'm not sure what else to add, but will try my best to answer any questions.

Many thanks,

Chris.
This task depends upon

Closed by  Eric Belanger (Snowman)
Saturday, 25 August 2012, 13:21 GMT
Reason for closing:  None
Comment by Gerardo Exequiel Pozzi (djgera) - Saturday, 20 August 2011, 21:08 GMT
Broken firmware can trigger this. In that case use, if /dev/sr0 exists use archisodevice=/dev/sr0 as kernel parameter.

See if cdrom modules are loaded (sr_mod, cdrom), ata and scsi related (libata, scsi_mod) and module for your ata controller like ahci, sata_nv, ata_piix, etc), see if any error/warning message on dmesg.

cd/dvd/bd is pata, sata or scsi? is an LG?
Comment by chris_debian (chris_debian) - Sunday, 21 August 2011, 14:39 GMT
djgera,

Many thanks for your ideas. I can confirm that the following are loaded:

sr_mod
cdrom
libata
scsi_mod

The device isn't an LG and I assume it's PATA, because it's not SATA. Other distros seem to recognise the CD as /dev/sr0.

When the media initially boots and I get the splash screen which lets me choose whether to install/ boot from harddisk/ check memory etc, some of the keyboard is not mapped correctly, so I can only add the letters 'arch' to the kernel line. The letter 'i' for example, is not available. For this reason, I cannot see how I can pass options to the kernel.

I currently have Sabayon linux installed on the PC that Arch won't boot on, so it seems strange to think it is a firmware issue, when other distros manage to install correctly.

Thank you for the offer of the workaround. It's a shame I was unable to get it to work. It would be good if this could be fixed as it is in other distros.

If I can provide any further information to anybody, please let me know what you need and I'll try to provide it.

Many thanks,

Chris.
Comment by Gerardo Exequiel Pozzi (djgera) - Sunday, 21 August 2011, 14:59 GMT
What keyboard layout you have? There is no keyboard remap at this stage, so imagine that you have an "us" keyboard, characters are present in that order.

On initramfs stage do you see /dev/sr0 ? (I guess yes, because sr_mod). You can also try to re-trigger udev events (with command: udevadm trigger) maybe the symlink to sr0 will be created.

Newer Linux versions are incompatible with some optical drive firmware versions (you will see lots of buffer i/o errors), or other kinds of problems. If you search on Internet you can see many many bugs about this without any solution if hardware vendor does not provide a fixed firmware.

Sabayon: with Linux 3.0?
Comment by chris_debian (chris_debian) - Tuesday, 13 September 2011, 15:25 GMT
Without a different style keyboard (English British layout), I don't see how this bug can be progressed. As I raised it, I'm going to close it.

Thanks for the help given.

Chris.
Comment by chris_debian (chris_debian) - Saturday, 25 August 2012, 13:20 GMT
  • Field changed: Percent Complete (100% → 0%)
I'd like to re-open this, as I managed to solve it so would like to document the workaround.

By pressing the 'Num Lock' key, I was able to use the rest of my keyboard. Once I had done this, I could enter 'archisodevice=/dev/sr0'. This permitted the boot to continue and solved the problem. Bug can then be closed.

Many thanks,

Chris.

Loading...