Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25682 - [initscripts] Clean up ANSI codes from /var/log/boot

Attached to Project: Arch Linux
Opened by Karol Błażewicz (karol) - Friday, 19 August 2011, 23:29 GMT
Last edited by Tom Gundersen (tomegun) - Saturday, 23 June 2012, 00:48 GMT
Task Type Bug Report
Category Arch Projects
Status Closed
Assigned To Tom Gundersen (tomegun)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Despite http://projects.archlinux.org/initscripts.git/commit/?id=d0b7d600da518778b2a5d7c08785ea328fbaf2e7 there are some ANSI codes left in the log.

The cleanup script should also remove ^[[161G and ^[[171G and maybe some other ones too.

sed -i -r -e 's/\^\[\[[0-9]?;?[0-9]?[0-9]?;?[0-9]?[0-9]?[ms]//g' \
-e 's/\^\[(\[151|%)G//g' \
-e 's/\^\[(\[161|%)G//g' \
-e 's/\^\[(\[171|%)G//g' /var/log/boot

Steps to reproduce:
[karol@black ~]$ tail /var/log/boot
Fri Aug 19 20:55:39 2011: :: Setting Hostname: black ^[[171G [BUSY] ^[[171G [DONE]
Fri Aug 19 20:55:39 2011: :: Setting Locale: pl_PL.UTF-8 ^[[171G [BUSY] ^[[171G [DONE]
Fri Aug 19 20:55:39 2011: :: Setting Consoles to UTF-8 mode ^[[171G [BUSY] ^[[171G [DONE]
Fri Aug 19 20:55:40 2011: :: Loading Keyboard Map: pl ^[[171G [BUSY] ^[[171G [DONE]
Fri Aug 19 20:55:40 2011: :: Loading Console Font: Lat2-Terminus16 ^[[171G [BUSY] ^[[171G [DONE]
Fri Aug 19 20:55:40 2011: :: Saving dmesg Log ^[[171G [BUSY] ^[[171G [DONE]
Fri Aug 19 20:55:40 2011: INIT: Entering runlevel: 3
Fri Aug 19 20:55:41 2011: :: Starting Syslog-NG ^[[171G [BUSY] ^[[171G [DONE]
Fri Aug 19 20:55:42 2011: :: Starting D-BUS system messagebus ^[[171G [BUSY] ^[[171G [DONE]
Fri Aug 19 20:55:42 2011: :: Starting acpid ^[[171G [BKGD] :: Starting gpm ^[[171G [BKGD^[[0;1

Another thing: look at the end of the last line" '[BKGD^[[0;1' - it's not removed either.
This task depends upon

Closed by  Tom Gundersen (tomegun)
Saturday, 23 June 2012, 00:48 GMT
Reason for closing:  Won't implement
Comment by Eric Belanger (Snowman) - Saturday, 20 August 2011, 00:27 GMT
perhaps we should replace:
sed -i -r -e 's/\^\[\[[0-9]?;?[0-9]?[0-9]?;?[0-9]?[0-9]?[ms]//g' \
-e 's/\^\[(\[151|%)G//g' /var/log/boot
by:
sed -i -r -e 's/\^\[\[[0-9]?;?[0-9]?[0-9]?;?[0-9]?[0-9]?[ms]//g' \
-e 's/\^\[(\[1[0-9]1|%)G//g' /var/log/boot


For the last one, there seems to be a missing closing bracket.
Comment by Eric Belanger (Snowman) - Saturday, 20 August 2011, 11:05 GMT Comment by Karol Błażewicz (karol) - Wednesday, 14 March 2012, 01:13 GMT
  • Field changed: Percent Complete (100% → 0%)
Not 100% sure if it's related to this (long closed) bug, but I'm setting up zram after starting the daemons and I noticed I get '^[[9;0]' in /var/log/boot

Sat Mar 10 12:26:21 2012: :: Starting privoxy [BKGD]
Sat Mar 10 12:26:21 2012: ^[[9;0]Setting up swapspace version 1, size = 51196 KiB
Sat Mar 10 12:26:21 2012: no label, UUID=be017b1d-00dd-4013-aa72-2313500ad82a
Comment by Allan McRae (Allan) - Saturday, 16 June 2012, 08:16 GMT
And now we have many, many codes....
Comment by Tom Gundersen (tomegun) - Saturday, 23 June 2012, 00:48 GMT
We will no longer filter the logs automatically. Use the right switch when viewing them with "less", write a script to do what you want, or something else...

Loading...