FS#25649 - Optical drive isn't detected anymore

Attached to Project: Arch Linux
Opened by Heiko Baums (cyberpatrol) - Thursday, 18 August 2011, 18:28 GMT
Last edited by Tom Gundersen (tomegun) - Thursday, 18 August 2011, 22:12 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


My DVD writer isn't detected anymore. There's no /dev/sr0 anymore and no /proc/sys/dev/cdrom. And the DVD writer is locked. That is, I can't open the tray with the writer's eject button anymore.

I don't know when this happened, but it's not that long ago that it has worked. It happens at least with these packages:

linux 3.0.2 and 3.0.3
udev 173-3
initscripts 2011.07.3-1
filesystem 2011.08-1
mkinitcpio 0.7.2-1

The DVD writer has worked at least 3 days ago. So this issue is most likely related to the kernel updates from linux 3.0.1 to 3.0.2 and 3.0.3.

I encountered that the initscripts seem to be run before the kernel is fully initiallized, because there's dmesg output written to tty1 long after /etc/rc.sysinit is started and quite often long after the system has finished booting. But I can't say if this dmesg output is related to the optical drive. So this is probably a different issue.

My DVD writer is a Pioneer DVR-216D.
This task depends upon

Closed by  Tom Gundersen (tomegun)
Thursday, 18 August 2011, 22:12 GMT
Reason for closing:  None
Additional comments about closing:  Seems to have solved itself. Please reopen if it reappears.
Comment by Heiko Baums (cyberpatrol) - Thursday, 18 August 2011, 18:37 GMT
I should mention that there's nothing related to the dvd writer in dmesg.
Comment by Karol Błażewicz (karol) - Thursday, 18 August 2011, 19:13 GMT Comment by Heiko Baums (cyberpatrol) - Thursday, 18 August 2011, 19:48 GMT
I haven't seen both links, yet. But the second is not the reason because I don't have the modules piix loaded and no /dev/hdX. And it worked with udev 173-3.

I'll try the patch.
Comment by Heiko Baums (cyberpatrol) - Thursday, 18 August 2011, 21:16 GMT
For now I'll request closure of this bug as invalid.

What confuses me is that the DVD drive couldn't be opened at the reboot during the system selftest etc. When I shut down the system, and checked the cable connections, which have been all right, and started the computer again, I could open the DVD drive again with the eject button. And the drive was detected again by my linux-fbcondecor 3.0.2 which is almost identical with linux 3.0.2.

So maybe it was just a temporary issue - I doubt that it is a real hardware issue - or it has something to do with inconsistent module loading or hardware detection again, like all those issues with the sound cards, network cards, etc.

I'll keep a wary eye on it, and reopen this bug if it will happen again.