Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25571 - [moc] depends on db

Attached to Project: Arch Linux
Opened by Leo (levantis) - Sunday, 14 August 2011, 11:08 GMT
Last edited by Eric Belanger (Snowman) - Sunday, 14 August 2011, 23:18 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
new moc player can`t start without libdb, but does not include db as its dependency. installing db manually solves the problem

Additional info:
* package version: 20110528-3
* config and/or log files etc. : mocp: error while loading shared libraries: libdb-5.2.so: cannot open shared object file: No such file or directory

Steps to reproduce: run mocp with any of the switches
This task depends upon

Closed by  Eric Belanger (Snowman)
Sunday, 14 August 2011, 23:18 GMT
Reason for closing:  Not a bug
Comment by Karol Błażewicz (karol) - Sunday, 14 August 2011, 11:24 GMT
I don't have libdb installed and I have no problems in running moc 20110528-3 on my i686.
Comment by Jelle van der Waa (jelly) - Sunday, 14 August 2011, 11:41 GMT
[jelle@P8][~]%mocp
mocp: error while loading shared libraries: libdb-5.2.so: cannot open shared object file: No such file or directory

Moc really depends on db.
Comment by Jelle van der Waa (jelly) - Sunday, 14 August 2011, 11:42 GMT
Leo check your mirrors and install db.
Comment by Eric Belanger (Snowman) - Sunday, 14 August 2011, 18:07 GMT
Is your system up-to-date? db is a depends of several base packages so it should be installed.
Comment by Karol Błażewicz (karol) - Sunday, 14 August 2011, 18:15 GMT
Ah, so the package's name is db, not libdb - sure, I have it installed.
We expect users to have base group installed. Perl is in base group and perl depends on db. Does this mean db should be in base group?
Comment by Eric Belanger (Snowman) - Sunday, 14 August 2011, 18:29 GMT
@Karol: No, as it will be automaticallly installed when the base package which depends on it will be installed. So it doesn't need to be in base group.
Comment by Leo (levantis) - Sunday, 14 August 2011, 18:38 GMT
to: Eric, Karol: yes, that is my fault. I totally forgot about this policy. I do not update the system all the time, only occasionally. Sorry for causing the mess.
Although I still cannot get used to this dependency definition :)

Loading...