Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25535 - [kdeaccessibility-jovie] No Talkers

Attached to Project: Arch Linux
Opened by Mike Bonar (glide) - Friday, 12 August 2011, 12:54 GMT
Last edited by Andrea Scarpino (BaSh) - Monday, 12 September 2011, 15:48 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Andrea Scarpino (BaSh)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
There are no talkers installed with KDE's text to speech application, Jovie. When you select a talker in the configuration, it displays as invalid voice type.


Additional info:
KDE 4.7.0
Jovie 0.6.0


Steps to reproduce:
Launch Jovie, Configure > Talkers > Add... Choose any talker from the list.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Monday, 12 September 2011, 15:48 GMT
Reason for closing:  Not a bug
Additional comments about closing:  see the last comment
Comment by Ronald van Haren (pressh) - Monday, 15 August 2011, 07:32 GMT
Are these talkers supposed to be provided by Jovie or by some third party lib/app?
Comment by Mike Bonar (glide) - Monday, 15 August 2011, 13:55 GMT
Jovie supports espeak and festival synthesizers. These are not pulled in as dependencies.
Comment by Samuel Johnson (Samuel_Johnson) - Tuesday, 16 August 2011, 10:46 GMT
I had same issue. Speech-dispatcher uses pulseaudio by default. If you use alsa, configure speech-dispatcher to use alsa using 'spd-conf'.

Its working for me now.
Comment by Mike Bonar (glide) - Tuesday, 16 August 2011, 14:29 GMT
So, in order to get this working you must install one of two optional dependencies (espeak or festival) and run spd-conf to get speach-dispatcher working. Then you are able to select Talkers in the Jovie configuration. I'm not sure if this requires some tweaking to the arch package or just some notes in the wiki.
Comment by Andrea Scarpino (BaSh) - Tuesday, 16 August 2011, 14:42 GMT
I cannot test it yet, but I guess we should add some optional dependence here.
Comment by Samuel Johnson (Samuel_Johnson) - Tuesday, 16 August 2011, 14:52 GMT
It would be good if pacman forces user to choose one (or both) of the dependency as mandatory (does pacman have such a feature?) and tell user to run 'spd-conf' after install.
Comment by Andrea Scarpino (BaSh) - Tuesday, 16 August 2011, 15:32 GMT
No pacman cannot ask for what dependence you want to install, the best way is to put both espeak and festival as optional dependencies and let users choice their favourite.
spd-conf is provided by speech-dispatcher package which should print a post_install message.
Comment by Andrea Scarpino (BaSh) - Tuesday, 16 August 2011, 15:33 GMT
Oh wait. kdeaccessibility-jovie depends on speech-dispatcher and pacman -Qi speech-dispatcher says:
Optional Deps : festival: Speech output using Festival
espeak: Speech output using ESpeak
pulseaudio: PulseAudio support

Loading...