AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://projects.archlinux.org/aurweb.git/
Tasklist

FS#25524 - AUR should evaluate shell brace expansion

Attached to Project: AUR web interface
Opened by Olivier Mehani (shtrom) - Friday, 12 August 2011, 02:03 GMT
Last edited by Lukas Fleischer (lfleischer) - Saturday, 13 August 2011, 11:55 GMT
Task Type Bug Report
Category PKGBUILD Parser
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 1.8.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Sometimes, the source of a package doesn't match its name. See for example [0].

A simple variable substitution solves the problem, e.g. “source=(http://triq.net/files/${pkgname/-/_}-$pkgver.tar.gz)”, but the web parser doesn't handle this properly, and generates an incorrect URL.

[0] https://aur.archlinux.org/packages.php?ID=51465
This task depends upon

Closed by  Lukas Fleischer (lfleischer)
Saturday, 13 August 2011, 11:55 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Dupe of  FS#15043  and  FS#25210 .

Loading...