Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25506 - [ghostscript] pdf printing is no more possible.

Attached to Project: Arch Linux
Opened by Stephan Munsch (waldbaer59) - Thursday, 11 August 2011, 03:41 GMT
Last edited by Andreas Radke (AndyRTR) - Thursday, 01 September 2011, 03:44 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

After updating to ghostscript 9.04-1 printing is no more possible.
Downgrade to ghostscript 9.02-2 helps for the moment.

Additional info:
* package version: ghostscript 9.04-1

Reported error message:
lp: Unsupported format 'application/pdf'!
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Thursday, 01 September 2011, 03:44 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Thursday, 11 August 2011, 05:24 GMT
Please check, if this is solved in ghostscript 9.04-2.
Comment by william kray (williamkray) - Friday, 12 August 2011, 21:12 GMT
similar issues here, attempting to print test pages on my epson NX510 with avasys-supplied drivers resulted in an unknown file format error. after reboots and reinstalls, printing queuing succeeded, but pages were printed completely black. tried both 9.04-1 and 9.04-2 without success. successfully got printing to work with foomatic drivers (with lower quality prints), but a downgrade to ghostscript 9.02-2 allowed use of avasys drivers again.

arch x86_64
cups 1.4.8-1

i believe this should be marked an upstream bug.

EDIT: updated to ghostscript 9.04-3 with same results.
Comment by Phil Wheeler (Wheelsner) - Sunday, 14 August 2011, 11:08 GMT
I believe I'm having similar behaviour with printing to williamkray above. I am no longer able to network print to my EPSON SX610FW following the recent ghostscript upgrades (9.04-1,9.04-2, 9.04-3). The jobs stop in the queue following print but printer prints entirely black page.

According the the logs the print fails with a filter error, although I can't find any further details in cups/error_log that seem to be of use (attached). The CUPS web interface initially reports a failure of gstoraster however if I wait long enough this this clears and the job shows as successfully sent to the printer.

As above, downgrading to ghostscript 9.02-2 restores normal printing.

Apologies if this should be going upstream!

--------------
ARCH [testing] 2.6.39-ck

ghostscript 9.04-3
cups 1.4.8-2
gutenprint 5.2.7-2
--------------



   error_log (14.4 KiB)
Comment by Jeremy M. (jskier) - Sunday, 14 August 2011, 20:49 GMT
Same exact problem and downgrading solution that works with Canon printer (MX860).
Comment by Jay Tanzman (jt512) - Thursday, 18 August 2011, 03:13 GMT
I have been getting nothing but all-black pages using an EPSON Stylus_NX400 connected directly to the computer, using ghostscript-9.04-{1,2,3}. Printer works fine with ghustscript-9.02-2.
Comment by Andreas Radke (AndyRTR) - Thursday, 18 August 2011, 05:33 GMT
If nobody reports this upstream it won't get fixed.
Comment by Jeremy M. (jskier) - Thursday, 18 August 2011, 10:55 GMT
Reported in upstream:
Bug 692441 - http://bugs.ghostscript.com/show_bug.cgi?id=692441
Comment by Jeremy M. (jskier) - Thursday, 18 August 2011, 23:07 GMT
Jay or Willaim- perhaps you are a bit more adept with development processes? I'm struggling on providing enough information for the bug I opened in upstream. Thank you in advance for any help with this.
Comment by william kray (williamkray) - Friday, 19 August 2011, 17:43 GMT
i also don't have enough experience with ghostscript to know what logs or information is needed to solve this. i will do everything i can, if someone tells me how to gather logs or info for this issue.

from Chris @ the ghostscript bugtracker: "Without a Ghostscript command line and an example file, we're not going to be able to help." how do you call ghostscript from the command line? there is no man or info available. is there a way to show debugging output?
Comment by Jeremy M. (jskier) - Friday, 19 August 2011, 22:03 GMT
This probably won't help much but the command is "gs". I haven't used it before either.

$ gs --help
GPL Ghostscript 9.02 (2011-03-30)
Copyright (C) 2010 Artifex Software, Inc. All rights reserved.
Usage: gs [switches] [file1.ps file2.ps ...]
Most frequently used switches: (you can use # in place of =)
-dNOPAUSE no pause after page | -q `quiet', fewer messages
-g<width>x<height> page size in pixels | -r<res> pixels/inch resolution
-sDEVICE=<devname> select device | -dBATCH exit after last file
-sOutputFile=<file> select output file: - for stdout, |command for pipe,
embed %d or %ld for page #
Comment by Andreas Radke (AndyRTR) - Monday, 22 August 2011, 05:13 GMT
Please test 9.04-4, it has a fix included for broken color printing ( FS#25519  - upstream http://bugs.ghostscript.com/show_bug.cgi?id=691922). There can be more color issues for sure.

But the initial report says application/pdf filtering is broken. So please keep this bug for this pdf printing issue. Is color printing is still broken please open a new issue!
Comment by william kray (williamkray) - Saturday, 27 August 2011, 15:44 GMT
color printing is now fixed for me. v9.04-5.
Comment by Andreas Radke (AndyRTR) - Tuesday, 30 August 2011, 15:51 GMT
Is the pdf printing issue still present? Have you tried cups 1.5.0? Can you try a generic (PCL or whatever) driver?
Comment by Jeremy M. (jskier) - Thursday, 01 September 2011, 00:17 GMT
This issue appears to have been resolved.

Loading...