Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25439 - [xorg,linux]boot error : intel ips 0000:00:1f.6: failed to get i915 symbols, graphics turbo disabled

Attached to Project: Arch Linux
Opened by Julien ZOBRIST (jzobrist) - Sunday, 07 August 2011, 22:40 GMT
Last edited by Jan de Groot (JGC) - Monday, 03 October 2011, 14:16 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan de Groot (JGC)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Hi,

I have the following error during my laptop boot :

intel ips 0000:00:1f.6: failed to get i915 symbols, graphics turbo disabled

It appears with the new 3.0.1 kernel in the core repository.
The boot process continues, but the "graphics turbo disabled" and "MCP temp limit 90"(see the dmesg bellow) make me think that a thing may goes wrong with the performance of my laptop.
For example my laptop goes very warm and halt during expensive gpu usage (games, flash...)
I use proprietary nvidia drivers.

Here are some more informations :

uname -a
Linux blah 3.0-ARCH #1 SMP PREEMPT Sat Aug 6 16:49:00 CEST 2011 i686 Intel(R) Core(TM) i5 CPU M 430 @ 2.27GHz GenuineIntel GNU/Linux

dmesg | grep intel

[ 1.616349] intel_idle: MWAIT substates: 0x1120
[ 1.616351] intel_idle: v0.4 model 0x25
[ 1.616352] intel_idle: lapic_timer_reliable_states 0xffffffff
[ 5.815865] ACPI: acpi_idle yielding to intel_idle
[ 5.888867] intel ips 0000:00:1f.6: CPU TDP doesn't match expected value (found 25, expected 29)
[ 5.888885] intel ips 0000:00:1f.6: PCI INT A -> GSI 21 (level, low) -> IRQ 21
[ 5.888916] intel ips 0000:00:1f.6: failed to get i915 symbols, graphics turbo disabled
[ 5.889124] intel ips 0000:00:1f.6: IPS driver initialized, MCP temp limit 90

lspci

00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
01:00.0 VGA compatible controller: nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8192SE Wireless LAN Controller (rev 10)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)

This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 03 October 2011, 14:16 GMT
Reason for closing:  Not a bug
Comment by Francesco (teme) - Tuesday, 09 August 2011, 19:50 GMT
Hi all,
I have the same problem with this CPU:
Linux edison 3.0-ARCH #1 SMP PREEMPT Sat Aug 6 16:18:35 CEST 2011 x86_64 Intel(R) Core(TM) i5 CPU M 520 @ 2.40GHz GenuineIntel GNU/Linux

I have only the FAIL in Module's section when Archlinux boot, but I don't have problem with performance.
Comment by Pierre Wacrenier (mota) - Wednesday, 10 August 2011, 11:17 GMT
Hi all,

same problem with a dell XPS 15 L501x.

I've got a second screen plugged on the mini-displayport.

At boot the message is the same as above. Then, the driver seems to be re-launched and working well.
When X is started, I try to resize with xrandr the two screens to proper resolutions but the external screen turns black.

I don't know if it is related but I had this issue when I switched to the 3.0 kernel.

uname -a:

Linux epicure 3.0-ARCH #1 SMP PREEMPT Sat Aug 6 16:18:35 CEST 2011 x86_64 Intel(R) Core(TM) i5 CPU M 460 @ 2.53GHz GenuineIntel GNU/Linux

xrandr command:

xrandr --output LVDS1 --mode 1366x768 --pos 0x0 --rotate normal --output DP1 --mode 1440x900 --pos 1366x0 --rotate normal
Comment by Damjan Dimitrioski (gnu_D) - Sunday, 14 August 2011, 08:37 GMT
Workaround:
blacklist intel_ips
and the message disappeared, I found this fix from: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/651104

At least it works now on my Dell Inspiron N5010.
Comment by Jan de Groot (JGC) - Thursday, 18 August 2011, 13:26 GMT
What about putting this in rc.conf:
MODULES=('intel-agp' 'i915' 'intel_ips')

That would make sure i915 is loaded before intel_ips.

I guess intel_ips is some kind of powersaving/turbo mode driver for the IGP.
Comment by Pierre Wacrenier (mota) - Thursday, 18 August 2011, 23:00 GMT
I have now the dual screen functional since I've upgraded to kernel 3.0.3 but still have a failure on loading the drivers at boot time.
Even by editing the rc.conf file the way you suggested.

Messages have changed, like you can see in the dmes.log file attached to this post.
Comment by dauerbaustelle (dauerbaustelle) - Monday, 22 August 2011, 10:54 GMT
*confirm*
Comment by Julien ZOBRIST (jzobrist) - Monday, 22 August 2011, 12:06 GMT
What is strange is that I don't have an Intel graphic chip but an Nvidia chip (GeForce GT 320M).

- Blacklist intel_ips do the trick for not displaying the message.

- adding : MODULES=('intel_agp' 'i915' 'intel_ips') causes a fatal error, i915 can't be loaded.
Comment by Jan de Groot (JGC) - Monday, 22 August 2011, 12:14 GMT
This is not a bug at all, just a logical warning message. The intel_ips driver controls powermanagement for core i* CPUs with integrated GPU. When the i915 driver isn't loaded, the module will print that message, which is harmless if you don't use the integrated GPU. As hybrid graphics is still not functional on linux afaik, it's normal that i915 will not load when not using the intel chip for graphics.

Loading...