Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25419 - [rxvt-unicode] icon information from rxvt-unicode.desktop is not picked up for urxvt

Attached to Project: Community Packages
Opened by Arun (g33k) - Saturday, 06 August 2011, 10:03 GMT
Last edited by Sébastien Luttringer (seblu) - Friday, 06 April 2012, 11:49 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sébastien Luttringer (seblu)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
There is a mismatch between the "Name" field in rxvt-unicode.desktop field and the executable. Due to this if an user starts rxvt-unicode from commandline with "urxvt" command, the icons are not picked up.

Additional info:
* package version(s)= 9.12-1
* config and/or log files etc. = Gnome 3.0, Arch x86_64

Steps to reproduce:
* Open a terminal, run "urxvt"

Actual behavior:
The application window has an "unknown" icon. Note that running "rxvt-unicode" from Applications, shows the expected Icon, but if I restart gnome-shell (Alt-F2, and then type in "r"), the icon information again lost.

Expected behavior:
The application window should have "Terminal" icon as specified in the .desktop file.

Workaround:
* Create a file urxvt.desktop in ~/.local/share/applications
* Change "Name" in .desktop file to "urxvt"
This task depends upon

Closed by  Sébastien Luttringer (seblu)
Friday, 06 April 2012, 11:49 GMT
Reason for closing:  Not a bug
Comment by Alexander F Rødseth (xyproto) (trontonic) - Thursday, 22 March 2012, 21:59 GMT
For the latest version, rxvt-unicode.desktop has Icon=terminal
Is this still a problem?
Comment by Sébastien Luttringer (seblu) - Saturday, 24 March 2012, 15:17 GMT
IMHO, if there 2 different fields (Name and Exec) it's to allow Name to be different from Exec.

I tested your solution and this doesn't work on gnome3 and awesome. Icon in taskbar is still default.

Without link, i wondering why name is rxvt-unicode instead of urxvt/urxvtc/urxvt-tabbed. This would allow us to have icon to choice right urxvt we want to run.

rxvt-unicode is not used on man-pages, program names etc. Only for TERMCAP, this have meaning, it's shared by differend urxvt* programs.

Loading...