Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25384 - [krb5] install aclocal file

Attached to Project: Arch Linux
Opened by Christian Hesse (eworm) - Wednesday, 03 August 2011, 11:28 GMT
Last edited by Stéphane Gaudreault (stephane) - Sunday, 02 October 2011, 20:49 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To Stéphane Gaudreault (stephane)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
krb5 does not install /usr/share/aclocal/ac_check_krb5.m4
That causes some package installations to fail, e.g. I can not install gq (http://sourceforge.net/projects/gqclient/) from git.

Additional info:
krb5 1.9.1-3

Steps to reproduce:
* install krb5
* get gq git
* try to build it

Patch is attached.
This task depends upon

Closed by  Stéphane Gaudreault (stephane)
Sunday, 02 October 2011, 20:49 GMT
Reason for closing:  Fixed
Additional comments about closing:  krb5-1.9.1-4 in [testing]
Comment by Stéphane Gaudreault (stephane) - Monday, 26 September 2011, 23:18 GMT Comment by Christian Hesse (eworm) - Tuesday, 27 September 2011, 06:32 GMT
gq from git compiles and work fine. Thanks a lot!
Comment by Christian Hesse (eworm) - Tuesday, 27 September 2011, 11:22 GMT
Uh, I missed something... The prefix within the file is incorrect.

sed -i "/KRB5ROOT=/s/\/local//" ${pkgdir}/usr/share/aclocal/ac_check_krb5.m4

However I still have to run configure with "--with-kerberos5=yes" (instead of "--with-kerberos5=/usr"...). Suppose this is ok?
Comment by Stéphane Gaudreault (stephane) - Tuesday, 27 September 2011, 14:55 GMT
I just added the sed line to the package. Please download and try again (same url as above).
Comment by Christian Hesse (eworm) - Tuesday, 27 September 2011, 17:35 GMT
Works perfectly now. Thanks!

Loading...