Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#25305 - [jre] LWJGL games crash with JRE 7

Attached to Project: Community Packages
Opened by Jeff Cook (cookiecaper) - Friday, 29 July 2011, 07:10 GMT
Last edited by Thomas Dziedzic (tomd123) - Wednesday, 17 August 2011, 03:06 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Thomas Dziedzic (tomd123)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No



Minecraft and Revenge of the Titans, both games that utilize, crash since installing jre 7-1 earlier today. This is something involving ld and/or missing libraries. I am using x64.

Other complaints and additional detail has been filed at:

This ldd output is consistent on custom-built lwjgl and the sos included with both ROTT and Minecraft: => (0x00007fff257ff000) => /lib/ (0x00007ff9156da000) => /usr/lib/ (0x00007ff91539b000) => /usr/lib/ (0x00007ff915188000) => /usr/lib/ (0x00007ff914f7e000) => /usr/lib/ (0x00007ff914d76000) => /usr/lib/ (0x00007ff914b70000) => /lib/ (0x00007ff914953000) => not found => /lib/ (0x00007ff9145f1000) => /usr/lib/ (0x00007ff9143d6000) => /lib/ (0x00007ff9141d2000) => /usr/lib/ (0x00007ff913fc7000) => /usr/lib/ (0x00007ff913dc1000)
/lib/ (0x00007ff915c2b000) => /usr/lib/ (0x00007ff913bbf000) => /usr/lib/ (0x00007ff9139b9000)

ldd on
$ ldd /opt/java/jre/lib/amd64/ => (0x00007fff3fd2f000) => /opt/java/jre/lib/amd64/ (0x00007ffad0ce9000) => not found => /opt/java/jre/lib/amd64/ (0x00007ffad0a6a000) => not found => /lib/ (0x00007ffad0709000) => not found => /lib/ (0x00007ffad0486000) => /lib/ (0x00007ffad0282000) => not found => /opt/java/jre/lib/amd64/ (0x00007ffad0071000)
/lib/ (0x00007ffad11bd000) => not found
This task depends upon

Closed by  Thomas Dziedzic (tomd123)
Wednesday, 17 August 2011, 03:06 GMT
Reason for closing:  Upstream
Additional comments about closing:  it is upstream after all
Comment by Jeff Cook (cookiecaper) - Friday, 29 July 2011, 07:16 GMT
Just tried with jre 7-2 and get the same results, though I didn't try logging in/out or resourcing my profile.
Comment by Jelle van der Waa (jelly) - Friday, 29 July 2011, 09:22 GMT
Please report it under community packages and include [jre] to your title
Comment by Jelle van der Waa (jelly) - Friday, 29 July 2011, 09:23 GMT Comment by Thomas Dziedzic (tomd123) - Friday, 29 July 2011, 13:41 GMT
the above link is all I can recommend.

Please contact mojang and the other game.
I can not do anything about this.
Comment by Jeff Cook (cookiecaper) - Friday, 29 July 2011, 23:58 GMT
I am not sure that this is not a packaging bug. As stated in the thread on lwjgl's forums (,4085.0.html) , sudo ldconfig /opt/java/jre/lib/amd64/ after installation makes Minecraft and ROTT work fine on JVM 7.
Comment by Thomas Dziedzic (tomd123) - Saturday, 30 July 2011, 00:40 GMT
"sudo ldconfig /opt/java/jre/lib/amd64/"
This doesn't fix the initial bug where it uses 32bit libraries instead of the 64bit ones does it?
Comment by Jeff Cook (cookiecaper) - Saturday, 30 July 2011, 00:51 GMT
It does appear to fix that bug for me, yes. jre 7-2.
Comment by Thomas Dziedzic (tomd123) - Wednesday, 03 August 2011, 15:18 GMT
I'm still unconvinced that this is a packaging bug.

jre6 also had the same missing links and worked fine.

I will wait for upstream to at least comment on the bugs before moving on.
Comment by Thomas Dziedzic (tomd123) - Monday, 08 August 2011, 03:44 GMT
Marking as upstream because there are other problems with minecraft and java 7.
Comment by Patrick Stewart (patstew) - Tuesday, 09 August 2011, 00:58 GMT
running "sudo ldconfig /opt/java/jre/lib/amd64/" fixes Revenge of the Titans for me with jre-7-3. Before, it failed to load with "java.lang.UnsatisfiedLinkError: Can't load library: /"
Comment by Thomas Dziedzic (tomd123) - Tuesday, 09 August 2011, 21:07 GMT
I made a jre6 package at
and a jdk6 package at
as a temporary solution for this issue.
Comment by Katrina L. Halliwell (canuckkat) - Saturday, 13 August 2011, 17:12 GMT
running "sudo ldconfig /opt/java/jre/lib/amd64/" fixes it for Minecraft and Spiral Knights, but I have to run it every time I log in. I didn't have this issue with jre6 heh.
Comment by Thomas Dziedzic (tomd123) - Saturday, 13 August 2011, 17:57 GMT
thanks for your feedback. The fact that it worked in jre6 is the major reason why I haven't "fixed" this yet because I think this is a library issue within lwjgl or minecraft and similar games.
Comment by Thomas Dziedzic (tomd123) - Wednesday, 17 August 2011, 03:06 GMT
as I thought, it seems that according to,4085.msg22080.html#msg22080 the problem was in lwjgl

this will be fixed as soon as those games start using the latest lwjgl with the fix in it.