Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25303 - [texlive-core,bin] ConTeXt compile error

Attached to Project: Arch Linux
Opened by Greedwolf DSS (marseille) - Friday, 29 July 2011, 04:07 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Monday, 30 September 2013, 05:56 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Rémy Oudompheng (remyoudompheng)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
ConTeXt in texlive-core can't work. It say that cont-en.fmt is missing.

Additional info:
* package version(s)
texlive-core 2010.22154-1 and texlive-bin 2010.1-8
* config and/or log files etc.
.texlive/texmf-var/luatex-cache/context/6300afb4995fe38c77e9b86ed1ef1028/formats/cont-en.fmt: No such file or directory
MTXrun | fatal error: return code: 1


Steps to reproduce:
I read the wiki about context's format, then I followed the wiki to search in the ConTeXt wiki. And I did the same as it say" luatools --generate; context --make", but when I compiled the source file, the error happened.

Source file:
\starttext
Hello, World!
\stoptext
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Monday, 30 September 2013, 05:56 GMT
Reason for closing:  No response
Comment by Greedwolf DSS (marseille) - Saturday, 30 July 2011, 06:45 GMT
I think it's a bug, when I do "luatools --generate; context --make" in Debian, it do work normally.
Comment by Rémy Oudompheng (remyoudompheng) - Saturday, 30 July 2011, 10:18 GMT
Please try the attached patch to /usr/bin/mtxrun
Comment by Greedwolf DSS (marseille) - Saturday, 30 July 2011, 14:12 GMT
It just do the same, same error message: cont-en.fmt: No such file or directory.
Comment by Greedwolf DSS (marseille) - Saturday, 30 July 2011, 15:07 GMT
Oh, I think you talked about texlive 2011, I don't find "local ownpath = environment.ownpath or dir.current()" in texlive 2010 but in texlive 2011. But when I enable 'testing' and install texlive 2011, 'mtxrun --generate' is normal, but 'context --make' say "I can't find file `catc-ini.mkiv'.
Comment by Magnus Therning (magus) - Tuesday, 21 February 2012, 11:47 GMT
I still have to apply Remy's patch in order to successfully run `context --generate`! Then I run into another error, but that's reported in #28560
Comment by Gerardo Exequiel Pozzi (djgera) - Tuesday, 07 May 2013, 05:32 GMT
status?

Loading...