Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#25292 - [linux] Cannot reboot, init 6, shutdown -r now

Attached to Project: Arch Linux
Opened by Reon Toerien (mips1) - Thursday, 28 July 2011, 09:37 GMT
Last edited by Tobias Powalowski (tpowa) - Saturday, 18 February 2012, 06:35 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Medium
Priority Normal
Reported Version testbuild (specify!)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No


Version: Releng 20110610
Architecture: Dual ISO
CPU: i686 (Celeron M 1.4GHz)
Media: USB Flash

I've installed arch on my HP nx6110 laptop using the dual architecture 20110610 releng iso from usb flash.

The system will not restart on issuing a reboot, init 6 or shutdown -r now commands. It just hangs after "[ xxx.xxxxxx] Restarting system." which then requires you to power down the system via the power button.

This happens when logged in as root or as a normal users (sudoers file updated). I've also disabled all startup daemons in rc.conf for testing.

I've created a thread on the Arch forums with screenshots, and links to pastebin for stuff like strace & some config files,
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Saturday, 18 February 2012, 06:35 GMT
Reason for closing:  Upstream
Comment by Reon Toerien (mips1) - Thursday, 28 July 2011, 15:22 GMT
If a dev needs access to this laptop just let me know how to do this behind NAT as I have SSH enabled and very willing to provide access.
Comment by Reon Toerien (mips1) - Friday, 29 July 2011, 09:29 GMT
Looks like I'm not alone, some else with a HP nx8220 posted on the forum experiencing the exact same issue.
Comment by Deniz Dogan (damd) - Friday, 29 July 2011, 11:52 GMT
That's me. It's an HP Compaq nx8220. This happens on a clean Arch Linux install (from a netinstall CD) with all the default settings.
Comment by Reon Toerien (mips1) - Friday, 29 July 2011, 12:50 GMT Comment by Reon Toerien (mips1) - Saturday, 30 July 2011, 07:41 GMT
Just enabled the [testing] repo and upgraded to the linux 3.0-2 kernel and the problem is still present.
Comment by Tom Gundersen (tomegun) - Monday, 26 September 2011, 14:32 GMT
This is almost certainly an upstream bug, if you get as far as "[ xxx.xxxxxx] Restarting system." it means that user-space shut down correctly and that the kernel is telling the hw to reboot. There has been changes in the reboot code recently, but I don't know if your machines should be affected.

See for instance

I guess a bisection would be very helpful...