Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25273 - [lxpanel] Attempting to open the menu results in segfault

Attached to Project: Community Packages
Opened by Ryan DeShone (ardichoke) - Tuesday, 26 July 2011, 17:26 GMT
Last edited by Angel Velasquez (angvp) - Thursday, 28 July 2011, 23:19 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Angel Velasquez (angvp)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 12
Private No

Details

Description:
Clicking on the menu icon, or running lxpanelctl menu from the command line results in lxpanel segfaulting with the following error.

(lxpanel:4925): Gtk-CRITICAL **: IA__gtk_widget_get_requisition: assertion `requisition != NULL' failed

This appears to be a known bug in lxpanel that has been patched already according to the LXDE bugtracker:

http://sourceforge.net/tracker/index.php?func=detail&aid=3378371&group_id=180858&atid=894869

Additional info:
* package version: 0.5.7-1

Steps to reproduce:

Install lxpanel 0.5.7-1, launch lxpanel, click the menu button (or run lxpanelctl menu from the command line)
This task depends upon

Closed by  Angel Velasquez (angvp)
Thursday, 28 July 2011, 23:19 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed on 0.5.7-2 next time I hope they do a new release of lxpanel :S
Comment by Nesser (Decepteiskon) - Wednesday, 27 July 2011, 15:57 GMT
Same here, Linux kernel26 2.6.39.3-1 x64 and LxPanel 0.5.7-1, opening start menu results in the same error:

(lxpanel:2437): Gtk-CRITICAL **: IA__gtk_widget_get_requisition: assertion `requisition != NULL' failed
Errore di segmentazione (segfault)

I think that the severity of this bug should elevated to middle/high, because the panel is nearly unusable (i'm using a LxTerminal window now, and i've noticed that the last update 0.1.10-1 broke the transparency, but according to blog.lxde.org is a known bug and should be fixed by upstream).
Comment by wombalton (wombalton) - Wednesday, 27 July 2011, 21:09 GMT
apparently its fixed upstream: http://sourceforge.net/tracker/?func=detail&aid=3378371&group_id=180858&atid=894869

can someone please make an update to the archpackage?

Loading...