Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25245 - Downloading official Arch PKGBUILD as tar.gz

Attached to Project: Arch Linux
Opened by nan (someonerandom) - Sunday, 24 July 2011, 16:21 GMT
Last edited by Andrea Scarpino (BaSh) - Sunday, 24 July 2011, 22:42 GMT
Task Type Feature Request
Category Web Sites
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

It's possible to view the official package files like PKGBUILD and additional script files at the description site of a package. On the left you have the possibility to view the SVN entries of that package. Problem is, that it's very complicated to download all these single files if you want to build an official package by your own. With AUR you have the possibility to download all package contents as Tarball (or PKGBUILD). It would be nice if this feature could be implemented to the official Arch packages.

Example: http://www.archlinux.org/packages/extra/x86_64/a2ps/

It would be nice if under "Package actions" is a link like "Download buildfiles" as Tarball.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Sunday, 24 July 2011, 22:42 GMT
Reason for closing:  Not a bug
Comment by Karol Błażewicz (karol) - Sunday, 24 July 2011, 16:52 GMT Comment by nan (someonerandom) - Sunday, 24 July 2011, 21:31 GMT
Ups, thanks!

Loading...