Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25181 - [privoxy-3.0.17] logrotate whines about wrong permission

Attached to Project: Community Packages
Opened by solsTiCe (zebul666) - Tuesday, 19 July 2011, 22:43 GMT
Last edited by Lukas Fleischer (lfleischer) - Thursday, 21 July 2011, 12:55 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Lukas Fleischer (lfleischer)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

One need to add a line like
su privoxy privoxy
in /etc/logrotate.d/privoxy
to make logrotate stops whinning about:
error: skipping "/var/log/privoxy/jarfile" because parent directory has insecure permissions (It's world writable or writable by group which is not "root") Set "su" directive in config file to tell logrotate which user/group should be used for rotation.
error: skipping "/var/log/privoxy/logfile" because parent directory has insecure permissions (It's world writable or writable by group which is not "root") Set "su" directive in config file to tell logrotate which user/group should be used for rotation.
This task depends upon

Closed by  Lukas Fleischer (lfleischer)
Thursday, 21 July 2011, 12:55 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Dupe of  FS#25176 .
Comment by Lukas Fleischer (lfleischer) - Thursday, 21 July 2011, 12:54 GMT
I already fixed that in 3.0.17-3, cf.  FS#25176 . If you were upgrading from 3.0.17-2, pacman(8) probably displayed a warning about the package and the existing log directory having different permissions. In that case, just `chgrp root /var/log/privoxy` manually (as root).

Loading...