Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#25178 - [glibc] Missing dependency "sed" and "gzip"

Attached to Project: Arch Linux
Opened by Kyle Fuller (kylef) - Tuesday, 19 July 2011, 17:22 GMT
Last edited by Florian Pritz (bluewind) - Tuesday, 19 July 2011, 19:25 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No


These packages are included in the base group, so no one has probably seen these error messages. They are actually dependencies for glibc, without them you cannot use locale-gen.

# locale-gen
Generating locales...
/usr/sbin/locale-gen: line 33: sed: command not found
.UTF-8/usr/sbin/locale-gen: line 35: sed: command not found
.../usr/sbin/locale-gen: line 38: sed: command not found

# pacman -S sed

# locale-gen
Generating locales...
en_US.UTF-8...character map file `UTF-8' not found: No such file or directory
default character map file `ANSI_X3.4-1968' not found: No such file or directory

# ls /usr/share/i18n/charmaps/ | grep UTF

# pacman -S gzip

# locale-gen
Generating locales...
en_US.UTF-8... done
en_US.ISO-8859-1... done
Generation complete.
This task depends upon

Closed by  Florian Pritz (bluewind)
Tuesday, 19 July 2011, 19:25 GMT
Reason for closing:  Not a bug
Comment by Gerardo Exequiel Pozzi (djgera) - Tuesday, 19 July 2011, 18:01 GMT
, and gzip (explicited) and sed needs glibc the you have a circular dependency.

Normally dependencies to {base} packages are unlisted. If you do not install {base} group completelly, is supposed that you know what are you doing.