Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25176 - [privoxy] logrotate errors due to insecure permissions

Attached to Project: Community Packages
Opened by I Said Socks (socks) - Tuesday, 19 July 2011, 14:18 GMT
Last edited by Lukas Fleischer (lfleischer) - Wednesday, 20 July 2011, 08:21 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Lukas Fleischer (lfleischer)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
1)
logrotate skips /var/log/privoxy/* due to "insecure permissions".
The solution is to add the option "su root privoxy" to /etc/logrotate.d/privoxy.
2)
With the above fix, logrotate still fails:
error: stat of /var/log/privoxy/jarfile failed: No such file or directory
IIRC the default logfile is /var/log/privoxy/logfile, and I don't know what this jarfile is.
The solution would be to use /var/log/privoxy/* as the target.

Additional info:
privoxy 3.0.17-2

Steps to reproduce:
run: logrotate /etc/logrotate.d/privoxy
This task depends upon

Closed by  Lukas Fleischer (lfleischer)
Wednesday, 20 July 2011, 08:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 3.0.17-3.

Loading...