Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25169 - [nfs-utils] mount attempts with sec=krb5 result in ‘access denied’

Attached to Project: Arch Linux
Opened by Maxime de Roucy (akira86) - Tuesday, 19 July 2011, 10:56 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 11 June 2012, 13:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
kerberos works, nfs works when I don't use kerberos, but :
# mount -t nfs4 -o sec=krb5 server.lan:/directory /mnt
mount.nfs4: access denied by server while mounting server.lan:/directory

It's exactly the same issue as :
http://www.novell.com/support/viewContent.do?externalId=7008928&sliceId=1

(same warning in /var/log/daemon.log)

I tried with the new libtirpc 0.2.2... but it didn't work, I think I had to rebuild nfs-utils too.
But when I tried to build nfs-utils 1.2.3-3 (from testing) the ./configure fail and say it doesn't find the libtirpc library.
Then I give up... and fall back to the standard libtirpc and nfs-utils packages.

Additional info:
* core/nfs-utils 1.2.3-3
* core/libtirpc 0.2.1-3
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 11 June 2012, 13:31 GMT
Reason for closing:  No response
Comment by Tobias Powalowski (tpowa) - Wednesday, 17 August 2011, 06:50 GMT
should be fixed with latest packages, please confirm.
Comment by Maxime de Roucy (akira86) - Tuesday, 23 August 2011, 09:50 GMT
update to :
core/nfs-utils 1.2.4-2
core/libtirpc 0.2.2-2

doesn't solve the problem.
Comment by Allan McRae (Allan) - Saturday, 02 June 2012, 12:38 GMT
Status?

Loading...