Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25163 - [kde] Symbol lookup errors after update

Attached to Project: Arch Linux
Opened by Edmundas Braslauskas (Tsynique) - Monday, 18 July 2011, 21:55 GMT
Last edited by Andrea Scarpino (BaSh) - Tuesday, 26 July 2011, 10:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The following errors appear after a recent system update:

kate: symbol lookup error: /usr/lib/libnepomukutils.so.4: undefined symbol: _ZNK19QAbstractProxyModel8itemDataERK11QModelIndex

dolphin: symbol lookup error: /usr/lib/libQtSvg.so.4: undefined symbol: _ZN15QGraphicsObject16staticMetaObjectE

kmix: symbol lookup error: /usr/lib/libnepomukutils.so.4: undefined symbol: _ZNK19QAbstractProxyModel8itemDataERK11QModelIndex

/usr/bin/automoc4: symbol lookup error: /usr/bin/automoc4: undefined symbol: _ZN9QListData11detach_growEPii

PACKAGE VERSIONS:

$ pacman -Q kdelibs kdebase-dolphin
kdelibs 4.6.5-2
kdesdk-kate 4.6.5-1
kdebase-dolphin 4.6.5-1
kdemultimedia-kmix 4.6.5-2
automoc4 0.9.88-2

Tried using a blank user, no luck. More info https://bbs.archlinux.org/viewtopic.php?pid=962438#p962438
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Tuesday, 26 July 2011, 10:21 GMT
Reason for closing:  Not a bug
Comment by Jelle van der Waa (jelly) - Tuesday, 19 July 2011, 18:41 GMT
Assigned to Bash since he might know what the hell is going on in kde ;)
Looks like: https://bbs.archlinux.org/viewtopic.php?pid=962633
Check if your mirror is up 2 date http://www.archlinux.org/mirrors/status/ and update!
Comment by Edmundas Braslauskas (Tsynique) - Tuesday, 26 July 2011, 09:33 GMT
Solved after deleting /usr/lib/eToken/ which contained some libQt* library files.

Loading...