Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25110 - [modemmanager] Failed to send USSD via D-Bus interface

Attached to Project: Arch Linux
Opened by KIV (kiv) - Tuesday, 12 July 2011, 10:57 GMT
Last edited by Ionut Biru (wonder) - Saturday, 28 April 2012, 12:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I attempt to send USSD query via ModemManager D-Bus interface.
I got error: "GDBus.Error:org.freedesktop.ModemManager.Modem.General: USSD terminated by network."
Direct access to /dev/ttyUSB2 and sending AT commands to send USSD works ok.
ModemManager version: 0.4.998-1.
Modem: Huawei Technologies Co., Ltd. E620 USB Modem
This task depends upon

Closed by  Ionut Biru (wonder)
Saturday, 28 April 2012, 12:14 GMT
Reason for closing:  Fixed
Additional comments about closing:  modemmanager 5.2.0
Comment by Jelle van der Waa (jelly) - Wednesday, 13 July 2011, 17:32 GMT
no clue what you are doing, please provide more info, do ome basic googling / check the forum
https://wiki.archlinux.org/index.php/USB_3G_Modem
Comment by KIV (kiv) - Wednesday, 13 July 2011, 17:50 GMT
I call method Initiate of interface org.freedesktop.ModemManager.Modem.Gsm.Ussd
Comment by Jelle van der Waa (jelly) - Thursday, 14 July 2011, 16:10 GMT
Please ask upstream
Comment by Jelle van der Waa (jelly) - Tuesday, 16 August 2011, 08:57 GMT
Did you ask upstream yet?
Comment by KIV (kiv) - Wednesday, 17 August 2011, 21:17 GMT Comment by Jelle van der Waa (jelly) - Sunday, 28 August 2011, 20:08 GMT Comment by Ionut Biru (wonder) - Sunday, 28 August 2011, 20:26 GMT
which means that is included in our current modemmanager 0.5 package
Comment by Jelle van der Waa (jelly) - Sunday, 28 August 2011, 21:28 GMT
so KIV does it work now?
Comment by KIV (kiv) - Monday, 29 August 2011, 07:26 GMT
No.
ModemManager 0.5-1 shows same error.
Comment by Ionut Biru (wonder) - Monday, 29 August 2011, 07:29 GMT
then report a new bug upstream

Loading...