Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25106 - [lilypond] PDF file does not have bar lines

Attached to Project: Community Packages
Opened by Allen (allencch) - Tuesday, 12 July 2011, 06:32 GMT
Last edited by Sergej Pupykin (sergej) - Monday, 16 January 2012, 21:08 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Lilypond 2.14.1-2 when generating the PDF file, it does not produce bar lines automatically like previous version, 2.12.3-7.

Sometimes will fail with this message:
GNU LilyPond 2.14.1
Processing `test.ly'
Parsing...
Interpreting music...
Interpreting music... [8]
Preprocessing graphical objects...throw from within critical section.
Aborted

Sometimes does not have problem, but there will be no bar lines in PDF file.

Additional info:
Lilypond 2.14.1.2


Steps to reproduce:
lilypond test.ly
This task depends upon

Closed by  Sergej Pupykin (sergej)
Monday, 16 January 2012, 21:08 GMT
Reason for closing:  Fixed
Comment by Allen (allencch) - Tuesday, 12 July 2011, 06:38 GMT
The example files are attached, the test-2.12.pdf is the pdf generated with Lilypond 2.12.3-7.
test-2.14.pdf is generated with 2.14.1-2.

The test.ly is the source file.
Comment by Thomas Dziedzic (tomd123) - Tuesday, 12 July 2011, 06:40 GMT
please report this upstream
Comment by Sergej Pupykin (sergej) - Tuesday, 12 July 2011, 09:29 GMT
I was able to produce proper pdf with lilypond 2.14.1-2 on x86_64 from attached test.ly
Comment by Nicolò Barbon (smilzoboboz) - Friday, 25 November 2011, 19:41 GMT
I'm still always able to reproduce this bug with lilypond 2.14.2-1 and lilypon-devel (2.15.19) from AUR.
I think one ore more dependencies are not set.
Comment by renato (nareto) - Monday, 12 December 2011, 11:37 GMT
I can confirm this bug on 2.14.2. I've also submitted a bug upstream, here:
http://lists.gnu.org/archive/html/bug-lilypond/2011-12/msg00410.html
Comment by Sergej Pupykin (sergej) - Wednesday, 14 December 2011, 09:13 GMT
please try lilypond-2.14.2-2
Comment by Nicolò Barbon (smilzoboboz) - Tuesday, 20 December 2011, 06:31 GMT
  • Field changed: Percent Complete (100% → 0%)
Really sorry to bother you again man, but also new package has that same issue. If you re-open I'll post my system config, lilypond logs and "test.ly" pdf outputs.
Comment by Sergej Pupykin (sergej) - Tuesday, 20 December 2011, 16:17 GMT
I can see vertical bars in pdf produced with current lilypond-2.14.2-3

\version "2.14.2"

%the following gives no barlines in pdf output
\relative c'' {
c1 | c1 | c1 |
}
Comment by renato (nareto) - Wednesday, 21 December 2011, 09:05 GMT
still not getting them here, see screenshot at
http://i.imgur.com/BWkuU.png
Comment by Nicolò Barbon (smilzoboboz) - Wednesday, 21 December 2011, 14:10 GMT
Still got that problem
Attached:
- Packages installed on my machine
- lilypond verbose log
- a newTest.ly containing the rows you asked to test
- resulting pdf...

This test was done after installing package 2.14.2-3 and then rebooting.
Comment by Sergej Pupykin (sergej) - Wednesday, 21 December 2011, 15:25 GMT
Please try

$ lilypond -V --ps test.ly

and view it with

$ gv test.ps
Comment by Nicolò Barbon (smilzoboboz) - Wednesday, 21 December 2011, 15:58 GMT
didn't had ghostscript viewer (I used to go straight to GIMP...), so I just installed it.
Anyway, bars still aren't there.
I run XFCE as DE, is it possible I missed to export some OS var that didn't export automatically?
Comment by renato (nareto) - Wednesday, 21 December 2011, 16:20 GMT
me too still not seeing bar lines, I'm attaching the verbose output of lilypond.

in the bug report upstream I recieved this reply:
http://lists.gnu.org/archive/html/bug-lilypond/2011-12/msg00412.html

so lilypond doesn't support the versions of ghostscript and fontforge we have on Arch?
   output (7.7 KiB)
Comment by Nicolò Barbon (smilzoboboz) - Wednesday, 21 December 2011, 16:41 GMT
actually seems to do (support) since Sergej is able to output well (and probabily others, as only 3 arch users are claiming/care about that bug).
Comment by Tanjeff-N. Moos (tanjeff) - Thursday, 29 December 2011, 16:42 GMT
I have this problem too: No bars. I noticed it a few month ago, and it is still there. Thus we are at least 4 Arch users.
Comment by Harald Holone (holone) - Saturday, 07 January 2012, 13:08 GMT
Problem confirmed with 2.14.2-3 on i686, 3.1.7-1-ARCH (upgraded today). I have the same problem on all of my machines running arch, all of which are fresh installs from December 2011.

When i install lilypond with the script on the lilypond site (http://download.linuxaudio.org/lilypond/binaries/linux-x86/lilypond-2.14.2-1.linux-x86.sh), everything works as expected. I notice that this install includes ghostscript 8.7, whereas the current arch version is 9.4.

@sergej: can you confirm that you're running lilypond from the arch repositories, and check if you have any older ghostscript libs on your machine? I also notice that you're running 64bit, however I don't know why that should make a difference.
Comment by Sergej Pupykin (sergej) - Monday, 09 January 2012, 10:24 GMT
I have only libgs.so.9 in /usr/lib and gs -V reports 9.04. Can not find older ghostscript.
Comment by Harald Holone (holone) - Monday, 09 January 2012, 14:16 GMT
When I downgrade to 2.12.3-7 (found at http://schlunix.org/archlinux/community/os/i686/), barlines work as expected, still using gs9.04. Upgrading to 2.14.1-1 from the same site reintroduces the problem.
Comment by Patrick McCarty (pnorcks) - Wednesday, 11 January 2012, 06:47 GMT
Rendering is okay for me with version 2.14.2 from [community], and with lilypond-devel 2.15.23 from AUR.

Can someone post their PS output (with corresponding input)? This should give a better idea if fontforge, ghostscript, or some other dependency is to blame for this issue.

Attached is my PS/PDF output from newTest.ly in Nicolò's comment above. Note that the exact command I used here is `lilypond -dno-point-and-click -dno-delete-intermediate-files newTest.ly` .

Edit: the output was produced with 2.14.2.
Comment by Allen (allencch) - Thursday, 12 January 2012, 14:32 GMT
Attached are my output from 2.14.2, using the same command as mentioned by Patrick. The result does not produce any bar.
Besides that, my fontforge version is 20111214-2, ghostscript 9.04-5, using Arch Linux 32-bit.
Comment by Harald Holone (holone) - Monday, 16 January 2012, 19:37 GMT
I just installed 2.14.2-4 (built yesterday by sergej), and it solves the problem on my machines (tested on two) :-)

Good job, Sergej!
Comment by Sergej Pupykin (sergej) - Monday, 16 January 2012, 21:08 GMT

Loading...