Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25090 - [redland][rasqal][liblrdf] possible improper includes

Attached to Project: Arch Linux
Opened by Ray Rashif (schivmeister) - Saturday, 09 July 2011, 23:29 GMT
Last edited by Ray Rashif (schivmeister) - Wednesday, 13 July 2011, 09:58 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andreas Radke (AndyRTR)
Andrea Scarpino (BaSh)
Giovanni Scafora (giovanni)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

From another BR I've found out a number of header files, mainly in redland, that may not have the proper includes. Can we patch them up while someone gets those changes upstream (if valid and not already reported)? I'm not opening separate BRs for this, since this is ultimately just one group of related software/libraries/packages.

These are also what cause build failures if the raptor1 package is installed alongside raptor. The affected files (see attached patches for the changes):

== redland ==
librdf.h
rdf_log.h
rdf_init.h
rdf_serializer.h

== rasqal ==
rasqal/rasqal.h

== liblrdf ==
lrdf.h

Reproducible by testing with a blank cc file including the 6 headers (attached):

$ g++ test.cc
This task depends upon

Closed by  Ray Rashif (schivmeister)
Wednesday, 13 July 2011, 09:58 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Problem is with includes in ardour or slv2.
Comment by Andrea Scarpino (BaSh) - Sunday, 10 July 2011, 23:00 GMT
  • Field changed: Category (Packages: Extra → Upstream Bugs)
I've no idea about this. You should definitely report this upstream: http://bugs.librdf.org
Comment by Ray Rashif (schivmeister) - Monday, 11 July 2011, 00:56 GMT
Yes I'll do that if no-one gets to it first.
Comment by Andreas Radke (AndyRTR) - Monday, 11 July 2011, 16:21 GMT
Yes please do so. And please ask the upstream rdf maintainer in irc channel #redland about your suggested header fixes. I'm usually logged into this channel too.
Comment by Ray Rashif (schivmeister) - Monday, 11 July 2011, 17:28 GMT

Loading...