Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25067 - [perl-gd] 2.44-4 not working

Attached to Project: Community Packages
Opened by Doug Whiteley (rezza) - Friday, 08 July 2011, 10:27 GMT
Last edited by Sergej Pupykin (sergej) - Monday, 11 July 2011, 14:02 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version 1.8.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

GD no longer loads for me in perl.

perl-gd is 2.44-4, perl is 5.14.1-3.

I try to "use GD" in any perl script, and the error given is:

Not a CODE reference at /usr/lib/perl5/core_perl/DynaLoader.pm line 213.
END failed--call queue aborted at /usr/lib/perl5/vendor_perl/GD.pm line 213.
This task depends upon

Closed by  Sergej Pupykin (sergej)
Monday, 11 July 2011, 14:02 GMT
Reason for closing:  Fixed
Comment by Doug Whiteley (rezza) - Monday, 11 July 2011, 08:20 GMT
Uh, perl-gd is in community.
Comment by Doug Whiteley (rezza) - Monday, 11 July 2011, 09:37 GMT
perl-gd is in community.
Comment by Sergej Pupykin (sergej) - Monday, 11 July 2011, 10:26 GMT
perl -MGD -e 'print "qwe";'

works for me as well as

$ cat q.pl
use GD;
print "qwe";

on x86_64
Comment by Doug Whiteley (rezza) - Monday, 11 July 2011, 13:08 GMT
On x86, both give the same error as in the bug report.
Comment by Sergej Pupykin (sergej) - Monday, 11 July 2011, 13:47 GMT
strange, neither rebuild, nor upgrading to 2.46 does not help, however on x86_64 it works ok...
Comment by Sergej Pupykin (sergej) - Monday, 11 July 2011, 14:02 GMT
fixed by

make CCFLAGS="-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"

it is probably upstream bug

Loading...