Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25061 - LibreOffice 3.4.1-1 requires libdb-5.2.so, but "db" is not listed as dependency

Attached to Project: Arch Linux
Opened by Duy Truong (jimreynold2nd) - Thursday, 07 July 2011, 22:43 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 08 July 2011, 05:44 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
LibreOffice 3.4.1-1 requires libdb-5.2.so, but "db" is not listed as dependency for "libreoffice" package

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
1) Fresh install with gnome desktop
2) run "pacman -Sy libreoffice"
3) run "libreoffice"

Error message:
/usr/lib/libreoffice/program/soffice.bin: error while loading shared libraries: libdb-5.2.so: cannot open shared object file: No such file or directory

Workaround:
Install "db": pacman -Sy db
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 08 July 2011, 05:44 GMT
Reason for closing:  Not a bug
Additional comments about closing:  we don't list each and every dependency that is covered by other deps.
Comment by Duy Truong (jimreynold2nd) - Thursday, 07 July 2011, 22:45 GMT
libreoffice 3.4.1-2 still has this problem.
Comment by Ionut Biru (wonder) - Thursday, 07 July 2011, 22:50 GMT
congrats, your workaround just broke gnome.

next time just use pacman -Syu package
Comment by Duy Truong (jimreynold2nd) - Thursday, 07 July 2011, 23:05 GMT
Hmm... That's interesting... How come installing "db" breaks gnome?! It's probably a separate issue.

But if you solved your "breaking gnome" with -Syu then it's probably because you had some out-of-date package that got updated with it, not related to this bug, which got solved by the update then.

Loading...