Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#25032 - [gnome-packagekit] Failed to obtain authentication in gpk-application

Attached to Project: Community Packages
Opened by Green (The_Green_Arrow) - Tuesday, 05 July 2011, 18:58 GMT
Last edited by Jonathan Conder (PirateJonno) - Friday, 08 July 2011, 10:56 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jonathan Conder (PirateJonno)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 1
Private No

Details

Description:
In gpk-application, I can't get the authentication graphical box in order to unlock some actions that required admin privileges. All I have is this error message : "Failed to obtain authentication"

Additional info:
* gnome-packagekit 3.0.3-1
This task depends upon

Closed by  Jonathan Conder (PirateJonno)
Friday, 08 July 2011, 10:56 GMT
Reason for closing:  Not a bug
Comment by Jonathan Conder (PirateJonno) - Thursday, 07 July 2011, 07:20 GMT
I cannot reproduce. Do you have consolekit & policykit installed? Do you start your login session using GDM or ck-launch-session? Can you authenticate with other programs that use policykit?
Comment by Green (The_Green_Arrow) - Thursday, 07 July 2011, 08:13 GMT
consolekit and polkit-gnome are installed. Session is started using GDM.

I've just realized I can't authenticate with the unlock button in User Accounts (in gnome-control-center) either.

I'm using gnome in fallback mode (might it be related to some gtk3 unimplemented things ?)

Comment by Jonathan Conder (PirateJonno) - Friday, 08 July 2011, 10:56 GMT
I've tried it in fallback mode and I get the same error. However, this is not a bug in gnome-packagekit. Please report it either upstream or elsewhere on this bug tracker. I'd say report it against polkit-gnome.

Loading...