Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24909 - Postgis fails to load with "version `GLIBC_2.14' not found" error

Attached to Project: Arch Linux
Opened by Maxime (yabo) - Monday, 27 June 2011, 13:44 GMT
Last edited by Andrea Scarpino (BaSh) - Monday, 27 June 2011, 14:20 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

Systematic crashes of database using postgis.


Additional info:
* community/postgis 1.5.2-1


Steps to reproduce:

$ createdb -E UTF8 -U postgres -T template0 test_db
$ psql -U postgres -d test_db -f /usr/share/postgresql/contrib/postgis-1.5/postgis.sql
SET
BEGIN
psql:/usr/share/postgresql/contrib/postgis-1.5/postgis.sql:59: ERROR: could not load library "/usr/lib/postgresql/postgis-1.5.so": /lib/libc.so.6: version `GLIBC_2.14' not found (required by /usr/lib/postgresql/postgis-1.5.so)

In an previously created database:

# select postgis_full_version();
ERROR: could not load library "/usr/lib/postgresql/postgis-1.5.so": /lib/libc.so.6: version `GLIBC_2.14' not found (required by /usr/lib/postgresql/postgis-1.5.so)
CONTEXT: SQL statement "SELECT postgis_lib_version()"
PL/pgSQL function "postgis_full_version" line 11 at SQL statement

My system is up to date and has glibc-2.14 installed

$ sudo pacman -Q glibc
glibc 2.14-4

Rebuilding the postgis package doesn't fix the problem.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Monday, 27 June 2011, 14:20 GMT
Reason for closing:  Not a bug
Additional comments about closing:  see comment
Comment by Maxime (yabo) - Monday, 27 June 2011, 13:48 GMT
Hmmm I didn't restart postgresql... Sorry for the noise.

Loading...