Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24863 - [hexedit] version `GLIBC_2.14' not found

Attached to Project: Arch Linux
Opened by Pierre Bourdon (delroth) - Friday, 24 June 2011, 17:19 GMT
Last edited by Ionut Biru (wonder) - Friday, 24 June 2011, 17:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
hexedit do not run on a fully upgraded x86_64 Archlinux system, outputting this error message when starting:

hexedit: /lib/libc.so.6: version `GLIBC_2.14' not found (required by hexedit)

Reproduced it on at least two Arch computers. I don't have an i686 installation to test this bug unfortunately.

Additional info:

extra/hexedit 1.2.12-3
core/glibc 2.13-5 (base)

Steps to reproduce:

# pacman -Syu
$ hexedit
This task depends upon

Closed by  Ionut Biru (wonder)
Friday, 24 June 2011, 17:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  hexedit 1.2.12-4
Comment by Pierre Bourdon (delroth) - Friday, 24 June 2011, 17:21 GMT
A simple rebuild of the package seems to solve the problem BTW.
Comment by Pierre Bourdon (delroth) - Friday, 24 June 2011, 17:29 GMT
... and got confirmation from a friend that the problem is occurring on an i686 Arch system. So it looks like a rebuild is needed for both architectures and not only x86_64.

Loading...