Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24831 - xfce4-panel blocks drag and drop

Attached to Project: Arch Linux
Opened by indianahorst (indianahorst) - Wednesday, 22 June 2011, 20:24 GMT
Last edited by Tobias Powalowski (tpowa) - Saturday, 20 August 2011, 06:07 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I have discovered the following issue in the last few days with my XFCE desktop:

When I try to drag a file from a filemanager (i.e. Krusader or Thunar) into a suiting application (i.e. a mp3 file into audacious, or a text file into gedit) which is minimized in the xfce panel, the application doesn't rise to drop the file into it (which is a really annoying behaviour).

Drag and drop in general works: if I drag and drop a file into an already visible application (i.e. a mp3 file into audacious with "always on top").

Downgrading xfce4-panel to version 4.8.3-1 and restarting it solves the problem, so that the xfce4-panel package is to blame.

Additional info:
* package version(s)
4.8.5-1

Steps to reproduce:
see above
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Saturday, 20 August 2011, 06:07 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Thursday, 23 June 2011, 04:35 GMT
Please report this upstream.
Comment by Tobias Powalowski (tpowa) - Friday, 19 August 2011, 06:58 GMT
I cannot reproduce this, dropping a file into audacicious brings it into front.
Comment by indianahorst (indianahorst) - Friday, 19 August 2011, 20:03 GMT
That's correct, I don't know which part of XFCE hast changed, but it works now flawlessly with xfce-panel 4.8.5-1.
This bug report can be closed from my point of view.

Loading...