Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24816 - [netcfg] Update from 2.5.5-1 to 2.6.1-1 breaks ethernet connection

Attached to Project: Arch Linux
Opened by Michael Kogan (Photon) - Tuesday, 21 June 2011, 17:40 GMT
Last edited by Rémy Oudompheng (remyoudompheng) - Sunday, 03 July 2011, 12:54 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Rémy Oudompheng (remyoudompheng)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After the update of netcfg from 2.5.5-1 to 2.6.1-1 no internet connection could be established. ifconfig reported no eth0 interface, only lo. A downgrade to 2.5.5 solved the problem.

Additional info:
* netcfg 2.6.1-1

Steps to reproduce:

Update netcfg to 2.6.1-1, configure /etc/rc.conf to use netcfg.
This task depends upon

Closed by  Rémy Oudompheng (remyoudompheng)
Sunday, 03 July 2011, 12:54 GMT
Reason for closing:  Not a bug
Comment by Ionut Biru (wonder) - Tuesday, 21 June 2011, 17:42 GMT
paste the profile
Comment by Michael Kogan (Photon) - Tuesday, 21 June 2011, 19:51 GMT
Do you mean the network configuration file? Here it is.
Comment by Rémy Oudompheng (remyoudompheng) - Sunday, 03 July 2011, 09:35 GMT
Works for me. Please give more details about your problem.
Comment by Michael Kogan (Photon) - Sunday, 03 July 2011, 12:35 GMT
I could solve the problem, it was due to the line

ROUTES=(!gateway)

in /etc/rc.conf. Don't know, where it came from, either from the standard configuration after the install or from some wiki entry. Problem is solved for me however.

Loading...