Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24811 - [xorg-xinit] inetutils needed as a dependency

Attached to Project: Arch Linux
Opened by Jason (Meyithi) - Tuesday, 21 June 2011, 09:06 GMT
Last edited by Jan de Groot (JGC) - Monday, 19 December 2011, 11:59 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:

/usr/bin/startx (line 127) makes a call to hostname -f to acquire FQDN when setting up xauth and returns an error when not found.

Additional info:
* package version(s)
xorg-xinit 1.3-03

Steps to reproduce:
Run startx with yp-tools/without net-tools
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 19 December 2011, 11:59 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in svn. Preparing a new package at this moment, so should be in repos soon.
Comment by Jelle van der Waa (jelly) - Wednesday, 22 June 2011, 09:22 GMT
hm i don't think we want xorg-xinit to depend on net-tools, since we want to move net-tools out.
Comment by Jason (Meyithi) - Wednesday, 22 June 2011, 10:08 GMT
Well, depending on who you ask, startx is deprecated as well, http://www.novell.com/linux/releasenotes/i586/openSUSE/11.4/#06 as an example.
Comment by Ronald van Haren (pressh) - Monday, 22 August 2011, 07:53 GMT
fyi, hostname is now moved to inetutils in [testing] and no longer is in net-tools 1.60.20110819cvs-1
Comment by Baeyens (berbae) - Wednesday, 12 October 2011, 09:51 GMT
So xorg-xinit needs a dependency on inetutils, because startx uses the hostname command.

The link to novel.com says that with display manager the setuid bit needs not be set for Xorg, but AFAIK in Arch it is set by installing the xorg-server package by default.

And not everyone wants to use a display manager.
Comment by Karol Błażewicz (karol) - Monday, 24 October 2011, 18:36 GMT
I think we should change this bug report's title so it can be found when searching for 'inetutils', otherwise people will report duplicate reports, like  FS#26599 .

Loading...