Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24798 - [firefox] doesn't start without gconf

Attached to Project: Arch Linux
Opened by nbvcxz (nbvcxz) - Monday, 20 June 2011, 12:35 GMT
Last edited by Ionut Biru (wonder) - Wednesday, 22 June 2011, 09:38 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
starting firefox 5.0 I receive:
/usr/lib/firefox-5.0/firefox-bin: symbol lookup error: /usr/lib/firefox-5.0/components/libmozgnome.so: undefined symbol: gconf_client_get_default

Additional info:
* package version(s): 5.0-1
I have no-gconf installed and it can be the reason, I thought firefox should be compiled with no gnome dependences


Steps to reproduce:
Install gvfs, no-gconf, firefox-5.0
start firefox
This task depends upon

Closed by  Ionut Biru (wonder)
Wednesday, 22 June 2011, 09:38 GMT
Reason for closing:  Not a bug
Comment by Ionut Biru (wonder) - Monday, 20 June 2011, 12:48 GMT
i don't consider this being a bug. is compiled with gconf support but if is not present, like in your situation, it will not load the libmozgnome.so component but continue to work without any problems.
Comment by nbvcxz (nbvcxz) - Monday, 20 June 2011, 13:10 GMT
thx wonder for quick response. In fact IT SHOULD WORK in the manner like you described. The problem is that it doesn't. In my situation although I don't have gconf installed and running, the firefox tries to load libmozgnome.so component (please look at the console output). Is there any way to solve this situation (eg. force firefox to start without checking gconf and loading libmozgnome.so)?
Comment by Andrea Scarpino (BaSh) - Monday, 20 June 2011, 14:19 GMT
  • Field changed: Summary ([firefox] → [firefox] doesn't start without gconf)
I confirm what Ioni said. Works here without gconf installed.
Comment by nbvcxz (nbvcxz) - Wednesday, 22 June 2011, 09:27 GMT
Ok - finally I discovered what was the problem. Firefox check NOT FOR GCONF DAEMON RUNNING, but for /usr/lib/libgconf-2.so presence. In my system it was "fake" library (from no-gconf). When there is no /usr/lib/libgconf in system - it works perfectly. And here the "bug" can be colsed.
Btw I need to recompile xfce4-ession with --disable-gnome to make rid of gconf dependency - anyone know why in official repo it is with gconf dependency?

Loading...