Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24789 - Swing applications unusable over SSH: Windows never get focused

Attached to Project: Arch Linux
Opened by Andrej Podzimek (andrej) - Sunday, 19 June 2011, 19:56 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Monday, 06 May 2013, 18:51 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andreas Radke (AndyRTR)
Guillaume ALAUX (galaux)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

All Swing-based applications (NetBeans, installers for most of the Java EE frameworks (Glassfish, WebSphere), FreeMind) are totally unusable when run remotely using the SSH X forwarding. The window never gets keyboard focus, although mouse events work (almost) fine. The focus stays with the previously used window and the Swing application never gets it, no matter how many times you click on it... This means you cannot type anything into the window and right clicks fail to get delivered as well.

There has been a bug of this kind in the past: http://www.google.com/#q=keyboard+focus+is+lost+in+swing+application

But perhaps those reports differ too much from this problem. In my case, Swing applications work perfectly when started locally. The focus is only lost when SSH X forwarding is used.

Additional info:
* package version(s)

openjdk6 6.b22_1.10.2-1
openssh 5.8p2-8
freemind 0.9.0-1

Please note: freemind is only mentioned as a quick example that can be used to reproduce the issue. *All* Swing-based applications are affected, not just freemind.

* config and/or log files etc.

Dunno where to look at. Will (of course) provide some config files/logs upon request.

Steps to reproduce:

1) SSH {to,from} an ArchLinux machine.
2) Run FreeMind remotely.
3) Try to focus the window and type something.
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Monday, 06 May 2013, 18:51 GMT
Reason for closing:  None
Additional comments about closing:  Please use forums for support request, you will get a better assistance. If a bug is found in a package please report here, or if a bug is found in the program please report to relevant bugtracker. Thanks.
Comment by Nicolas PENINGUY (npen) - Monday, 15 April 2013, 01:59 GMT
  • Field changed: Percent Complete (100% → 0%)
I have exactly the same problem but I don't understand the argument for closing. Keyboard is expected to work when running X application remotely. And it works from a Debian machine, but fails from my Arch laptop.
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 19 April 2013, 13:58 GMT
status with jre7-openjdk-7.u17_2.3.8-1?
Comment by Nicolas PENINGUY (npen) - Saturday, 20 April 2013, 21:39 GMT
I don't think jdk is the problem, my server is runing Fedora 17 and keyboard works if I ssh from Debian, but not from Arch. Anyway I tried with Oracle's JDK and latest OpenJDK but no change.

Only SSH and the X server are involved on Arch, but I have no idea on how to track the cause of this problem. Since the initial report is pretty old, I don't think it's related to a recent X update. May be a special configuration of SSH or X server on Arch?

Loading...