Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24745 - Gnome3 audio "error"

Attached to Project: Arch Linux
Opened by Bodo Kaiser (archer42) - Thursday, 16 June 2011, 21:13 GMT
Last edited by Allan McRae (Allan) - Saturday, 16 June 2012, 07:56 GMT
Task Type Support Request
Category Packages: Extra
Status Closed
Assigned To Jan Steffens (heftig)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The Audio Programm from Gnome3 doesnt find my Sound card. On the Panel is a speaker icon with a "x".
When I am looking in the System settings for Audio/Hardware there isn't any Device.
mplayer works without problem but mplayer works over its own backend (alsa). I think the problem is the migration of pulseaudio in gnome3 which doesnt work with my soundcard (realtek onboard Sound)

Additional info:
latest packages


Steps to reproduce:
Install gnome3
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 16 June 2012, 07:56 GMT
Reason for closing:  No response
Comment by Jan Steffens (heftig) - Friday, 17 June 2011, 07:59 GMT
Do you have a ~/.asoundrc?

Is /etc/asound.conf still unmodified? Check pacman -Qii pulseaudio-alsa.
Comment by Bodo Kaiser (archer42) - Friday, 17 June 2011, 08:52 GMT
pacman -Qii pulseaudio-alsa
Name : pulseaudio-alsa
Version : 1-2
URL : http://www.pulseaudio.org
Lizenzen : GPL
Gruppen : pulseaudio-gnome
Stellt bereit : Nichts
Hängt ab von : alsa-plugins pulseaudio
Optionale Abhängigkeiten: Nichts
Benötigt von : gnome-settings-daemon
Konflikt mit : Nichts
Ersetzt : Nichts
Installationsgröße : 12,00 K
Packer : Jan "heftig" Steffens <jan.steffens@gmail.com>
Architektur : any
Erstellt am : Fr 19 Nov 2010 17:31:54 CET
Installiert am : Mi 15 Jun 2011 18:36:15 CEST
Installationsgrund : Installiert als Abhängigkeit für ein anderes Paket
Installations-Skript : Nein
Beschreibung : ALSA Configuration for PulseAudio
Sicherungs-Dateien:
UNMODIFIED /etc/asound.conf

Is installed - seems to be youre packet ;)

Regards
Comment by Jan Steffens (heftig) - Friday, 17 June 2011, 08:53 GMT
Please attach the output of "pacmd list" and the contents of /proc/asound/pcm.
Comment by Bodo Kaiser (archer42) - Friday, 17 June 2011, 09:03 GMT
pacmd list
Es läuft kein PulseAudio-Dienst oder nicht als Sessiondienst.

00-00: ALC889 Analog : ALC889 Analog : playback 1 : capture 1
00-01: ALC889 Digital : ALC889 Digital : playback 1 : capture 1
00-02: ALC889 Analog : ALC889 Analog : capture 2
01-03: HDMI 0 : HDMI 0 : playback 1
/proc/asound/pcm (END)
Comment by Jan Steffens (heftig) - Friday, 17 June 2011, 09:31 GMT
How do you launch your gnome session?

Also, please try running "pulseaudio -v".
Comment by Bodo Kaiser (archer42) - Friday, 17 June 2011, 10:33 GMT
I am starting gnome with the gdm daemon

pulseaudio -v is very long:










I: alsa-util.c: Error opening PCM device front:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device hw:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround40:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround40:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround40:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround40:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround40:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround41:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround41:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround41:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround41:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround41:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround50:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround50:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround50:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround50:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround50:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround51:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround51:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround51:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround51:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround51:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround71:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround71:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround71:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround71:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0p' failed (-2)
I: alsa-util.c: Error opening PCM device surround71:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D1p' failed (-2)
I: alsa-util.c: Error opening PCM device iec958:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D1p' failed (-2)
I: alsa-util.c: Error opening PCM device iec958:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D1p' failed (-2)
I: alsa-util.c: Error opening PCM device iec958:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D1p' failed (-2)
I: alsa-util.c: Error opening PCM device iec958:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D1p' failed (-2)
I: alsa-util.c: Error opening PCM device iec958:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D1p' failed (-2)
I: alsa-util.c: Error opening PCM device iec958:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D1p' failed (-2)
I: alsa-util.c: Error opening PCM device iec958:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D1p' failed (-2)
I: alsa-util.c: Error opening PCM device iec958:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D1p' failed (-2)
I: alsa-util.c: Error opening PCM device iec958:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D1p' failed (-2)
I: alsa-util.c: Error opening PCM device iec958:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm.c: Unknown PCM a52:1
I: alsa-util.c: Error opening PCM device a52:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm.c: Unknown PCM a52:1
I: alsa-util.c: Error opening PCM device a52:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm.c: Unknown PCM a52:1
I: alsa-util.c: Error opening PCM device a52:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm.c: Unknown PCM a52:1
I: alsa-util.c: Error opening PCM device a52:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm.c: Unknown PCM a52:1
I: alsa-util.c: Error opening PCM device a52:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm.c: Unknown PCM a52:1
I: alsa-util.c: Error opening PCM device a52:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm.c: Unknown PCM a52:1
I: alsa-util.c: Error opening PCM device a52:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm.c: Unknown PCM a52:1
I: alsa-util.c: Error opening PCM device a52:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm.c: Unknown PCM a52:1
I: alsa-util.c: Error opening PCM device a52:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm.c: Unknown PCM a52:1
I: alsa-util.c: Error opening PCM device a52:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0c' failed (-2)
I: alsa-util.c: Error opening PCM device hw:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0c' failed (-2)
I: alsa-util.c: Error opening PCM device front:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0c' failed (-2)
I: alsa-util.c: Error opening PCM device hw:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D1c' failed (-2)
I: alsa-util.c: Error opening PCM device iec958:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D1c' failed (-2)
I: alsa-util.c: Error opening PCM device iec958:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0c' failed (-2)
I: alsa-util.c: Error opening PCM device hw:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0c' failed (-2)
I: alsa-util.c: Error opening PCM device front:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D0c' failed (-2)
I: alsa-util.c: Error opening PCM device hw:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D1c' failed (-2)
I: alsa-util.c: Error opening PCM device iec958:1: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC1D1c' failed (-2)
I: alsa-util.c: Error opening PCM device iec958:1: Datei oder Verzeichnis nicht gefunden
I: card.c: Created 0 "alsa_card.pci-0000_02_00.1"
I: alsa-sink.c: Successfully opened device hdmi:1.
I: alsa-sink.c: Selected mapping 'Digital Stereo (HDMI)' (hdmi-stereo).
I: alsa-sink.c: Successfully enabled mmap() mode.
I: alsa-sink.c: Successfully enabled timer-based scheduling mode.
I: (alsa-lib)control.c: Invalid CTL hdmi:1
I: alsa-mixer.c: Unable to attach to mixer hdmi:1: Datei oder Verzeichnis nicht gefunden
I: alsa-mixer.c: Successfully attached to mixer 'hw:1'
I: sink.c: Created sink 0 "alsa_output.pci-0000_02_00.1.hdmi-stereo" with sample spec s16le 2ch 44100Hz and channel map front-left,front-right
I: sink.c: alsa.resolution_bits = "16"
I: sink.c: device.api = "alsa"
I: sink.c: device.class = "sound"
I: sink.c: alsa.class = "generic"
I: sink.c: alsa.subclass = "generic-mix"
I: sink.c: alsa.name = "HDMI 0"
I: sink.c: alsa.id = "HDMI 0"
I: sink.c: alsa.subdevice = "0"
I: sink.c: alsa.subdevice_name = "subdevice #0"
I: sink.c: alsa.device = "3"
I: sink.c: alsa.card = "1"
I: sink.c: alsa.card_name = "HDA ATI HDMI"
I: sink.c: alsa.long_card_name = "HDA ATI HDMI at 0xfbbfc000 irq 56"
I: sink.c: alsa.driver_name = "snd_hda_intel"
I: sink.c: device.bus_path = "pci-0000:02:00.1"
I: sink.c: sysfs.path = "/devices/pci0000:00/0000:00:03.0/0000:02:00.1/sound/card1"
I: sink.c: device.bus = "pci"
I: sink.c: device.vendor.id = "1002"
I: sink.c: device.vendor.name = "ATI Technologies Inc"
I: sink.c: device.product.id = "aa30"
I: sink.c: device.product.name = "HD48x0 audio"
I: sink.c: device.string = "hdmi:1"
I: sink.c: device.buffering.buffer_size = "65536"
I: sink.c: device.buffering.fragment_size = "32768"
I: sink.c: device.access_mode = "mmap+timer"
I: sink.c: device.profile.name = "hdmi-stereo"
I: sink.c: device.profile.description = "Digital Stereo (HDMI)"
I: sink.c: device.description = "HD48x0 audio Digital Stereo (HDMI)"
I: sink.c: alsa.mixer_name = "ATI R6xx HDMI"
I: sink.c: alsa.components = "HDA:1002aa01,00aa0100,00100100"
I: sink.c: module-udev-detect.discovered = "1"
I: sink.c: device.icon_name = "audio-card-pci"
I: source.c: Created source 0 "alsa_output.pci-0000_02_00.1.hdmi-stereo.monitor" with sample spec s16le 2ch 44100Hz and channel map front-left,front-right
I: source.c: device.description = "Monitor of HD48x0 audio Digital Stereo (HDMI)"
I: source.c: device.class = "monitor"
I: source.c: alsa.card = "1"
I: source.c: alsa.card_name = "HDA ATI HDMI"
I: source.c: alsa.long_card_name = "HDA ATI HDMI at 0xfbbfc000 irq 56"
I: source.c: alsa.driver_name = "snd_hda_intel"
I: source.c: device.bus_path = "pci-0000:02:00.1"
I: source.c: sysfs.path = "/devices/pci0000:00/0000:00:03.0/0000:02:00.1/sound/card1"
I: source.c: device.bus = "pci"
I: source.c: device.vendor.id = "1002"
I: source.c: device.vendor.name = "ATI Technologies Inc"
I: source.c: device.product.id = "aa30"
I: source.c: device.product.name = "HD48x0 audio"
I: source.c: device.string = "1"
I: source.c: module-udev-detect.discovered = "1"
I: source.c: device.icon_name = "audio-card-pci"
I: alsa-sink.c: Using 2,0 fragments of size 32768 bytes (185,76ms), buffer size is 65536 bytes (371,52ms)
I: alsa-sink.c: Time scheduling watermark is 20,00ms
I: core-util.c: Successfully enabled SCHED_RR scheduling for thread, with priority 5.
I: alsa-sink.c: Starting playback.
I: module.c: Loaded "module-alsa-card" (index: #4; argument: "device_id="1" name="pci-0000_02_00.1" card_name="alsa_card.pci-0000_02_00.1" tsched=yes ignore_dB=no card_properties="module-udev-detect.discovered=1"").
I: module-udev-detect.c: Card /devices/pci0000:00/0000:00:03.0/0000:02:00.1/sound/card1 (alsa_card.pci-0000_02_00.1) module loaded.
I: alsa-util.c: Failed to set hardware parameters on plug:hw:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:hw:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:hw:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:hw:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:hw:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:hw:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:iec958:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:hw:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:iec958:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:hw:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:iec958:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:hw:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:iec958:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:hw:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:iec958:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:hw:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:iec958:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:hw:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:iec958:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:iec958:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:iec958:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:iec958:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:iec958:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:iec958:0: Das Argument ist ungültig
I: (alsa-lib)pcm.c: Unknown PCM a52:0
I: alsa-util.c: Error opening PCM device a52:0: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm.c: Unknown PCM a52:0
I: alsa-util.c: Error opening PCM device a52:0: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm.c: Unknown PCM a52:0
I: alsa-util.c: Error opening PCM device a52:0: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm.c: Unknown PCM a52:0
I: alsa-util.c: Error opening PCM device a52:0: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm.c: Unknown PCM a52:0
I: alsa-util.c: Error opening PCM device a52:0: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm.c: Unknown PCM a52:0
I: alsa-util.c: Error opening PCM device a52:0: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm.c: Unknown PCM a52:0
I: alsa-util.c: Error opening PCM device a52:0: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm.c: Unknown PCM a52:0
I: alsa-util.c: Error opening PCM device a52:0: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm.c: Unknown PCM a52:0
I: alsa-util.c: Error opening PCM device a52:0: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm.c: Unknown PCM a52:0
I: alsa-util.c: Error opening PCM device a52:0: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D3p' failed (-2)
I: alsa-util.c: Error opening PCM device hdmi:0: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D3p' failed (-2)
I: alsa-util.c: Error opening PCM device hdmi:0: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D3p' failed (-2)
I: alsa-util.c: Error opening PCM device hdmi:0: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D3p' failed (-2)
I: alsa-util.c: Error opening PCM device hdmi:0: Datei oder Verzeichnis nicht gefunden
I: (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D3p' failed (-2)
I: alsa-util.c: Error opening PCM device hdmi:0: Datei oder Verzeichnis nicht gefunden
I: alsa-util.c: Failed to set hardware parameters on plug:hw:0: Das Argument ist ungültig
I: alsa-util.c: Failed to set hardware parameters on plug:iec958:0: Das Argument ist ungültig
I: card.c: Created 1 "alsa_card.pci-0000_00_1b.0"
I: alsa-sink.c: Successfully opened device front:0.
I: alsa-sink.c: Selected mapping 'Analog Stereo' (analog-stereo).
I: alsa-sink.c: Successfully enabled mmap() mode.
I: alsa-sink.c: Successfully enabled timer-based scheduling mode.
I: (alsa-lib)control.c: Invalid CTL front:0
I: alsa-mixer.c: Unable to attach to mixer front:0: Datei oder Verzeichnis nicht gefunden
I: alsa-mixer.c: Successfully attached to mixer 'hw:0'
I: sink.c: Created sink 1 "alsa_output.pci-0000_00_1b.0.analog-stereo" with sample spec s16le 2ch 44100Hz and channel map front-left,front-right
I: sink.c: alsa.resolution_bits = "16"
I: sink.c: device.api = "alsa"
I: sink.c: device.class = "sound"
I: sink.c: alsa.class = "generic"
I: sink.c: alsa.subclass = "generic-mix"
I: sink.c: alsa.name = "ALC889 Analog"
I: sink.c: alsa.id = "ALC889 Analog"
I: sink.c: alsa.subdevice = "0"
I: sink.c: alsa.subdevice_name = "subdevice #0"
I: sink.c: alsa.device = "0"
I: sink.c: alsa.card = "0"
I: sink.c: alsa.card_name = "HDA Intel"
I: sink.c: alsa.long_card_name = "HDA Intel at 0xfbff4000 irq 55"
I: sink.c: alsa.driver_name = "snd_hda_intel"
I: sink.c: device.bus_path = "pci-0000:00:1b.0"
I: sink.c: sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
I: sink.c: device.bus = "pci"
I: sink.c: device.vendor.id = "8086"
I: sink.c: device.vendor.name = "Intel Corporation"
I: sink.c: device.product.id = "3a3e"
I: sink.c: device.product.name = "82801JI (ICH10 Family) HD Audio Controller"
I: sink.c: device.form_factor = "internal"
I: sink.c: device.string = "front:0"
I: sink.c: device.buffering.buffer_size = "65536"
I: sink.c: device.buffering.fragment_size = "32768"
I: sink.c: device.access_mode = "mmap+timer"
I: sink.c: device.profile.name = "analog-stereo"
I: sink.c: device.profile.description = "Analog Stereo"
I: sink.c: device.description = "Internes Audio Analog Stereo"
I: sink.c: alsa.mixer_name = "Realtek ALC889"
I: sink.c: alsa.components = "HDA:10ec0889,1458a022,00100004"
I: sink.c: module-udev-detect.discovered = "1"
I: sink.c: device.icon_name = "audio-card-pci"
I: source.c: Created source 1 "alsa_output.pci-0000_00_1b.0.analog-stereo.monitor" with sample spec s16le 2ch 44100Hz and channel map front-left,front-right
I: source.c: device.description = "Monitor of Internes Audio Analog Stereo"
I: source.c: device.class = "monitor"
I: source.c: alsa.card = "0"
I: source.c: alsa.card_name = "HDA Intel"
I: source.c: alsa.long_card_name = "HDA Intel at 0xfbff4000 irq 55"
I: source.c: alsa.driver_name = "snd_hda_intel"
I: source.c: device.bus_path = "pci-0000:00:1b.0"
I: source.c: sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
I: source.c: device.bus = "pci"
I: source.c: device.vendor.id = "8086"
I: source.c: device.vendor.name = "Intel Corporation"
I: source.c: device.product.id = "3a3e"
I: source.c: device.product.name = "82801JI (ICH10 Family) HD Audio Controller"
I: source.c: device.form_factor = "internal"
I: source.c: device.string = "0"
I: source.c: module-udev-detect.discovered = "1"
I: source.c: device.icon_name = "audio-card-pci"
I: alsa-sink.c: Using 2,0 fragments of size 32768 bytes (185,76ms), buffer size is 65536 bytes (371,52ms)
I: alsa-sink.c: Time scheduling watermark is 20,00ms
I: alsa-sink.c: Hardware volume ranges from -177,00 dB to 2,00 dB.
I: alsa-sink.c: Fixing base volume to -2,00 dB
I: alsa-sink.c: Using hardware volume control. Hardware dB scale supported.
I: alsa-sink.c: Using hardware mute control.
I: core-util.c: Successfully enabled SCHED_RR scheduling for thread, with priority 5.
I: alsa-sink.c: Starting playback.
I: alsa-source.c: Successfully opened device front:0.
I: alsa-source.c: Selected mapping 'Analog Stereo' (analog-stereo).
I: alsa-source.c: Successfully enabled mmap() mode.
I: alsa-source.c: Successfully enabled timer-based scheduling mode.
I: (alsa-lib)control.c: Invalid CTL front:0
I: alsa-mixer.c: Unable to attach to mixer front:0: Datei oder Verzeichnis nicht gefunden
I: alsa-mixer.c: Successfully attached to mixer 'hw:0'
I: source.c: Created source 2 "alsa_input.pci-0000_00_1b.0.analog-stereo" with sample spec s16le 2ch 44100Hz and channel map front-left,front-right
I: source.c: alsa.resolution_bits = "16"
I: source.c: device.api = "alsa"
I: source.c: device.class = "sound"
I: source.c: alsa.class = "generic"
I: source.c: alsa.subclass = "generic-mix"
I: source.c: alsa.name = "ALC889 Analog"
I: source.c: alsa.id = "ALC889 Analog"
I: source.c: alsa.subdevice = "0"
I: source.c: alsa.subdevice_name = "subdevice #0"
I: source.c: alsa.device = "0"
I: source.c: alsa.card = "0"
I: source.c: alsa.card_name = "HDA Intel"
I: source.c: alsa.long_card_name = "HDA Intel at 0xfbff4000 irq 55"
I: source.c: alsa.driver_name = "snd_hda_intel"
I: source.c: device.bus_path = "pci-0000:00:1b.0"
I: source.c: sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
I: source.c: device.bus = "pci"
I: source.c: device.vendor.id = "8086"
I: source.c: device.vendor.name = "Intel Corporation"
I: source.c: device.product.id = "3a3e"
I: source.c: device.product.name = "82801JI (ICH10 Family) HD Audio Controller"
I: source.c: device.form_factor = "internal"
I: source.c: device.string = "front:0"
I: source.c: device.buffering.buffer_size = "65536"
I: source.c: device.buffering.fragment_size = "32768"
I: source.c: device.access_mode = "mmap+timer"
I: source.c: device.profile.name = "analog-stereo"
I: source.c: device.profile.description = "Analog Stereo"
I: source.c: device.description = "Internes Audio Analog Stereo"
I: source.c: alsa.mixer_name = "Realtek ALC889"
I: source.c: alsa.components = "HDA:10ec0889,1458a022,00100004"
I: source.c: module-udev-detect.discovered = "1"
I: source.c: device.icon_name = "audio-card-pci"
I: alsa-source.c: Using 2,0 fragments of size 32768 bytes (185,76ms), buffer size is 65536 bytes (371,52ms)
I: alsa-source.c: Time scheduling watermark is 20,00ms
I: alsa-source.c: Hardware volume ranges from -16,00 dB to 30,00 dB.
I: alsa-source.c: Fixing base volume to -30,00 dB
I: alsa-source.c: Using hardware volume control. Hardware dB scale supported.
I: alsa-source.c: Using hardware mute control.
I: core-util.c: Successfully enabled SCHED_RR scheduling for thread, with priority 5.
I: alsa-source.c: Starting capture.
I: module.c: Loaded "module-alsa-card" (index: #5; argument: "device_id="0" name="pci-0000_00_1b.0" card_name="alsa_card.pci-0000_00_1b.0" tsched=yes ignore_dB=no card_properties="module-udev-detect.discovered=1"").
I: module-udev-detect.c: Card /devices/pci0000:00/0000:00:1b.0/sound/card0 (alsa_card.pci-0000_00_1b.0) module loaded.
I: module-udev-detect.c: Found 2 cards.
I: module.c: Loaded "module-udev-detect" (index: #6; argument: "").
I: module.c: Loaded "module-bluetooth-discover" (index: #7; argument: "").
I: module.c: Loaded "module-esound-protocol-unix" (index: #8; argument: "").
I: module.c: Loaded "module-native-protocol-unix" (index: #9; argument: "").
I: module.c: Loaded "module-gconf" (index: #10; argument: "").
I: module-default-device-restore.c: Restored default sink 'alsa_output.pci-0000_00_1b.0.analog-stereo'.
I: module-default-device-restore.c: Restored default source 'alsa_input.pci-0000_00_1b.0.analog-stereo'.
I: module.c: Loaded "module-default-device-restore" (index: #11; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #12; argument: "").
I: module.c: Loaded "module-always-sink" (index: #13; argument: "").
I: module.c: Loaded "module-intended-roles" (index: #14; argument: "").
I: module.c: Loaded "module-suspend-on-idle" (index: #15; argument: "").
I: module.c: Loaded "module-console-kit" (index: #16; argument: "").
I: module.c: Loaded "module-position-event-sounds" (index: #17; argument: "").
I: module.c: Loaded "module-cork-music-on-phone" (index: #18; argument: "").
W: main.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
I: main.c: Start des Daemons abgeschlossen.
E: module-gconf.c: Unable to read or parse data from client.
I: module.c: Unloading "module-gconf" (index: #10).
I: module.c: Unloaded "module-gconf" (index: #10).
I: module-suspend-on-idle.c: Source alsa_input.pci-0000_00_1b.0.analog-stereo idle for too long, suspending ...
I: alsa-source.c: Device suspended...
I: module-suspend-on-idle.c: Sink alsa_output.pci-0000_00_1b.0.analog-stereo idle for too long, suspending ...
I: alsa-sink.c: Device suspended...
I: module-suspend-on-idle.c: Sink alsa_output.pci-0000_02_00.1.hdmi-stereo idle for too long, suspending ...
I: alsa-sink.c: Device suspended...

I also attached the rc.conf so you see whats all getting started:
cat /etc/rc.conf
#
# /etc/rc.conf - Main Configuration for Arch Linux
#

# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# DAEMON_LOCALE: If set to 'yes', use $LOCALE as the locale during daemon
# startup and during the boot process. If set to 'no', the C locale is used.
# HARDWARECLOCK: set to "UTC" or "localtime", any other value will result
# in the hardware clock being left untouched (useful for virtualization)
# Note: Using "localtime" is discouraged.
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
# USECOLOR: use ANSI color sequences in startup messages
# VERBOSE: Verbose level (from 1 to 8). man 3 syslog for level info
#
LOCALE="de_DE.UTF-8"
DAEMON_LOCALE="no"
HARDWARECLOCK="localtime"
TIMEZONE="Europe/Berlin"
KEYMAP="de-latin1-nodeadkeys"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"
VERBOSE="3"

# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# MODULES: Modules to load at boot-up. Blacklisting is no longer supported.
# Replace every !module by an entry as on the following line in a file in
# /etc/modprobe.d:
# blacklist module
# See "man modprobe.conf" for details.
#
MODULES=(!mii !r8169 !pcspkr !snd-mixer-oss !snd-pcm-oss !snd-hwdep !snd-page-alloc !snd-pcm !snd-timer !snd !snd-hda-codec !snd-hda-intel !soundcore mii r8169 pcspkr snd-mixer-oss snd-pcm-oss snd-hwdep snd-page-alloc snd-pcm snd-timer snd snd-hda-codec snd-hda-intel soundcore fuse)

# Udev settle timeout (default to 30)
UDEV_TIMEOUT=30

# Scan for FakeRAID (dmraid) Volumes at startup
USEDMRAID="no"

# Scan for BTRFS volumes at startup
USEBTRFS="no"

# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
# HOSTNAME: Hostname of machine. Should also be put in /etc/hosts
#
HOSTNAME="bodo_pc"

# Use 'ip addr' or 'ls /sys/class/net/' to see all available interfaces.
#
# Wired network setup
# - interface: name of device (required)
# - address: IP address (leave blank for DHCP)
# - netmask: subnet mask (ignored for DHCP)
# - gateway: default route (ignored for DHCP)
#
# Static IP example
# interface=eth0
# address=192.168.0.2
# netmask=255.255.255.0
# gateway=192.168.0.1
#
# DHCP example
# interface=eth0
# address=
# netmask=
# gateway=

interface=eth0
address=192.168.178.20
netmask=255.255.255.0
gateway=192.168.178.1

# Setting this to "yes" will skip network shutdown.
# This is required if your root device is on NFS.
NETWORK_PERSIST="no"

# Enable these netcfg profiles at boot-up. These are useful if you happen to
# need more advanced network features than the simple network service
# supports, such as multiple network configurations (ie, laptop users)
# - set to 'menu' to present a menu during boot-up (dialog package required)
# - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network.d
#
# This requires the netcfg package
#
#NETWORKS=(main)

# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
# - prefix a daemon with a ! to disable it
# - prefix a daemon with a @ to start it up in the background
#
# If something other takes care of your hardware clock (ntpd, dual-boot...)
# you should disable 'hwclock' here.
#
DAEMONS=(hwclock network netfs dbus rpcbind gdm)

Comment by Jan Steffens (heftig) - Friday, 17 June 2011, 10:46 GMT
Seems pulseaudio wasn't running at all.

After a fresh boot and login, there's no pulseaudio running?
Comment by Bodo Kaiser (archer42) - Friday, 17 June 2011, 11:29 GMT
I think I know the issuepulseaudio
When running "pulseaudio" on my local user I get:
E: core-util.c: Home directory /home/bodo not ours.

I had something similar once before using arch.
I am mounting my home-dir over nfs from the server. Unfortunatly not everying works proberly because of permissions.
Under Gentoo I had to add something with domains but I am not sure what this was.
Comment by Allan McRae (Allan) - Saturday, 02 June 2012, 12:44 GMT
Status?

Loading...