Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24742 - Add aufs2 again to the repos

Attached to Project: Arch Linux
Opened by Thomas Schneider (BlackLotus) - Thursday, 16 June 2011, 20:42 GMT
Last edited by Thomas Bächler (brain0) - Monday, 04 July 2011, 14:52 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
Since the 2.6.39 kernel update aufs2 was removed from the repos.There are people who build a system with a squashfs and aufs2 on /usr/ https://bbs.archlinux.org/viewtopic.php?id=91656
This update breaks the whole system.

Steps to reproduce:
1)Configure a system with aufs2.
2)Update your system

Iirc kernel26-pf (aur) has aufs2 integrated and is a 2.6.39 release.
This task depends upon

Closed by  Thomas Bächler (brain0)
Monday, 04 July 2011, 14:52 GMT
Reason for closing:  Won't implement
Additional comments about closing:  Maintenance of AUFS2 is a pain in the ass and it requires modifications to a vanilla kernel.
Comment by Tom Gundersen (tomegun) - Tuesday, 21 June 2011, 19:42 GMT
[edit: removed wrong info]
If you want to keep using it, I suggest using the AUR kernel you mentioned. Alternatively, there might be other ways to get the same result. E.g. btrfs support compression, maybe other file systems too?

On a general note though: a separate /usr is a really, really bad idea and you will run into problems with it sooner or later.
Comment by Thomas Schneider (BlackLotus) - Tuesday, 21 June 2011, 21:11 GMT
I use a Laptop with a small hd so the /usr compression was very helpful anyway to the point.Aside from many users still using and depending on aufs2 as an unionfs I wonder if can be really counted as a patch on the kernel.It's an additional module that can be build against the kernel.In fact file systems and driver have to and wouldn't it be bad to don't support something because it wasn't build into the vanilla kernel?Aufs is used by many live-distributions which now need to change there system and I personally don't know any good alternatives.
Doesn't the kernel count as vanilla even when something can be build against it?Or were there patches in the kernel that I'm not aware of.I always saw aufs2 as package that was build against the kernel but not in the kernel.If it is that way maybe you should remove every module that isn't in the mainline linux kernel.Try starting with nvidia.
Oh and I tried btrfs and it's not stable and not usable in my case szenario.(If you don't believe me try transparent compression)
Comment by Tom Gundersen (tomegun) - Tuesday, 21 June 2011, 22:14 GMT
Ah, you are right, I remembered wrongly (updated my previous comment to remove nonsense). You can simply compile aufs2 as a module, no need to patch the kernel. Does this work for you: <https://aur.archlinux.org/packages.php?ID=38249>?

If I remember correctly aufs2 was dropped as it was holding back the kernel (no upstream update).

I have been using btrfs with compression on one of my systems (kernel 3.0-rc4) without problems, but I guess YMMV as btrfs is still new.
Comment by GI Jack (GI_Jack) - Sunday, 03 July 2011, 01:30 GMT
This just broke my larch based livecd. Why did package AUFS2 disapear?
Comment by Martin Hertz (mhertz) - Sunday, 03 July 2011, 23:31 GMT
Jeez, if you need aufs2 then its in the aur, including an aufs2 patched kernel! This has allready been stated additionally! And yes, it was removed because it wasn't updated and where holding the kernel back, which you could easilly yourself have googled to learn, or simply check the kernel commits!

@BlackLotus: Please go look up the term vanilla!
Comment by GI Jack (GI_Jack) - Monday, 04 July 2011, 10:47 GMT
yeah, but I can't get the AUR of AUFS2 to compile as it depends on AUFS2 package for source code. The other package has a dead link for the source code.

I'd also like to have a vanilla arch kernel to prevent breakage on updates and for security reasons.
Comment by Valery (v50110) - Monday, 04 July 2011, 14:26 GMT
I support the author of this task!

We have some fileservers in production with Arch.
These servers holds up to 2000000000 files on each, this is over 1,5TB of diskspace.
We use our own backup system based on rsync+squashfs+aufs2 for everynight differential backup.
We try many other variants for backup, but this bunch give best result for us.
Yes, we use LTS kernel and all works fine at current time.
But sometime all will change and LTS-kernel becomes 3.0 or 3.1 or any else..
We should be ready to it and we should test all changes before updating.
But now we can't make it because the core component of our backup system is inaccessible.
This is big problem for us and we are in confusion.
Removal aufs was a bolt from the blue.

On the other side aufs git repository is maintained and updated for all latest kernels,
and even there are working packages in AUR:
https://aur.archlinux.org/packages.php?ID=49766
https://aur.archlinux.org/packages.php?ID=49927
(but we can't use unsupported pkg in production)

Why it is impossible to return aufs?

Please return aufs back in to repository!
Comment by Ionut Biru (wonder) - Monday, 04 July 2011, 14:39 GMT
it was removed because the aufs2 maintainer said that he doesn't have time to support 2.6.39 and doesn't know when the support will come.

looking in git now, i see that 2.6.39 is supported and also 3.0.0-rc4

Loading...