Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers

FS#24729 - AIF tries to mount LVM Volume Group and fails

Attached to Project: Release Engineering
Opened by Stefan Reuter (stefanr) - Wednesday, 15 June 2011, 00:10 GMT
Last edited by Dieter Plaetinck (Dieter_be) - Friday, 19 August 2011, 12:08 GMT
Task Type Bug Report
Category AIF
Status Closed
Assigned To Dieter Plaetinck (Dieter_be)
Architecture x86_64
Severity High
Priority High
Reported Version testbuild (specify!)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No


I tried installing Arch on my Lenovo T420s using the latest test iso (2011-06-10) as suggested in this thread:
Then I tried to setup full disc encryption with LVM as described in the Install Guide at
That step failed however with the error message
ERROR: process_filesystem needs a partition as $1

Looking at the log file ( I suspect that AIF tries to mount the volume group /dev/mapper/cryptpool which fails for obvious reasons:
[DEBUG UI ] inform: Phase 2: Mounting filesystems
[DEBUG UI ] inform: Mounting /dev/mapper/cryptpool () on
[DEBUG UI ] die_error process_filesystem needs a partition as $1

Then AIF exists.

The full logs are available at:
This task depends upon

Closed by  Dieter Plaetinck (Dieter_be)
Friday, 19 August 2011, 12:08 GMT
Reason for closing:  Fixed
Comment by Heather L (MoonSwan) - Tuesday, 05 July 2011, 18:08 GMT
I can confirm this behaviour and replicate it easily without the LVM. If I just use the dm-crypt method of encryption through the AIF installer, make one partition encrypted and then hit cancel after starting to encrypt another volume, AIF crashes with the same error as above. I can reliably make it crash to CLI with one, two or more encrypted volumes. The cancellation (using the Esc key or the menu's cancel button) seems to be a fairly reliable trigger for this type of error.

This behaviour was found in the Arch Releng ISO dated 06-10-2011 using the i686 installer. I haven't tested the x86_64 installer yet.
Comment by Dieter Plaetinck (Dieter_be) - Thursday, 18 August 2011, 19:14 GMT
I can confirm with 2011.08.18
no need for esc or cancel buttons to trigger.
happens to me with even a simple LVM setup (1 VG, 1 LV), it indeed tries to mount the VG.
Comment by Dieter Plaetinck (Dieter_be) - Friday, 19 August 2011, 10:59 GMT
confirmed fixed by user Tucos in 2011.08.19 (both interactive and 2 automatic installs were tested, to be sure)